Jenkins 2.346.3 Tomcat 9 APIs

Hello Jenkins Community,

Good afternoon.
I am currently installing Jenkins LTS version 2.346.3 + Tomcat 9 + Java 1.8
Both ARE compatible with Java 1.8 - as I verified that already.
I have a compatibility question however, base on the APIs Tomcat 9 provides.
Hoping someone might know.
Please see below.
~ John

Has anyone had PROBLEMS running Jenkins LTS version 2.346.3, with Tomcat 9 + Java 1.8?

Will Jenkins LTS 2.346.3 run with these TOMCAT 9 APIs?

	Tomcat 9 supports these API levels

	Servlet Spec		       	            4.0	
	JSP Spec			            2.3	
	EL Spec				            3.0	
	WebSocket Spec			    1.1	
	Authentication (JASPIC) Spec     1.1	
	Apache Tomcat Version		     9.0.x	
	Latest Released Version		     9.0.68	
	Supported Java Versions	    8 and later

Jenkins is only tested with the embedded Jetty that comes from the winstone project.

Tomcat may work but it is not tested against by any Jenkins developers and there is no automated tests that verify it.

1 Like

I’ve been running Jenkins on Tomcat9 since longer time without issues going through all the LTS versions up to 2.346.3
In Mai I’ve then switch Jenkins 2.346.3 on Tomcat9 to Java11 to prepare for the next LTS. Since 4 weeks running on 2.361.1, Tomcat 9 and Java11


Thanks for the feedback, Tim.

~ John


Thanks the for the reply. Understood.

That’s good to hear - thank you.

~ John


Quick question.
When using Tomcat + Jenkins WAR, how did you get by the CRUMB error?
I tried adding this to my CATALINA BAT but it did not work.


  set JAVA_OPTS=-Djenkins.model.Jenkins.crumbIssuerProxyCompatibility=true

I am still researching this…
Here is the error from the Tomcat logs.
I am getting this on my FIRST request to Jenkins inside Tomcat, when the Jenkins WAR gets exploded.
Basically I cannot get the first request to work! : - (

No valid crumb was included in request for /jenkins/pluginManager/installPlugins by admin.
Returning 403.

I never tried running Jenkins from an unconfigured state on tomcat. I have a docker image with all plugins and existing configuration comes from a mounted location and this works fine without issues. Also we run tomcat with https only.
I suggest to use JCasC to see if the problem exists with a fully configured Jenkins.

1 Like


Thanks for the reply.

Thanks for the idea (i.e. JCasC).

I have not looked into Docker yet, my organization still uses Tomcat + Jenkins.

~ John

1 Like