Couldn't get even "hello world" to run


This is my 1st trial with Jenkins, as I’m trying to experiment CI’s to choose one.

To my surprise, even following the hello world quick startup in:

couldn’t get anything sensible (to me) to get going.

That’s the log of what I see after then “save” buttom on last step.

I’ve read all the introductory tutorial too.
The log seems as if it has just examined my repo and yielded no action, even though there is file “Jenkinsfile” inside just as instructed.

So it looks like is private, so we can’t see whats going on.

That looks like the output of the branch indexing though, and lacking the sentence that says it discovers jenkinsfile, I have a feeling its either having trouble reading it, or the file isn’t actually in there.

If your not willing to make it public, can you screenshot the github file browser/main page for that repo?

Does the job show up in the multi branch pipeline folder (one level up from the log)?

Are you willing to screenshot your config at all?


I’ve made it private because I need to experiment CI’s on a private repo.
This repo was created purely for experimentation.

GH page of the repo:

I’m limited to a single media per post, thus will put another screenshot in subsequent post.

Yes I’m willing to screenshot anything. This is experimental.

your level 1 now, you should have more access

I’m not sure where is the multibranch pipeline folder, I’ve gone 1 hierarchy up from log and found myself in path “http://localhost:8080/job/experiment/”:

You’re on the right page, as that is the page for the job itself, but it’s definitely showing that no branches were discovered.

Can you post a screenshot of the branch source section in the job’s configure page?

If that is not the correct section/page, let me know:

That’s the one. It’s weird, but for some reason, it didn’t add a Discover Branches behaviour to your branch source. Can you click on Add Behavior and add a Discover Branches behaviour to your source?

1 Like

It seems to have resolved something.

Running for very long though.

That’s a little vague to be able to help. Does it show anything in the indexing log? Or does it stop when you refresh? Or even the Jenkins.log file on disk?

1 Like

Thanks for responding.

It is still in progress (forever).

The indexing log show success, but when I pressed on the progress bar, it brought me to “Console Output” and there I see this:

Branch indexing
00:05:44 Connecting to using interfan7/******
Obtained Jenkinsfile from b935395a56e61765afebdc805b6150b2b27d50d6
[Pipeline] Start of Pipeline
[Pipeline] node
Still waiting to schedule task
‘Jenkins’ doesn’t have label ‘docker’

Anyway it looks too complicated as I’ve merely followed the “Creating your first Pipeline” page in official doc, expected it to be simple and working to perform a single line shell command, because I wanted to try a few CI’s to have initial impression.

A teammate who had experience with Jenkins many years ago showed me how to create “Freestyle project” and it has worked in a minute.
Of course it doesn’t clone from SC, but seems like it would be simple to add this one as it shall be same as I’ve tried here (Multibranch Pipeline).
I’ll give this a try.

Thanks for support, the community seem to be great if I’ve received such help from you guys. :pray:t2:

that means your pipeline has an agent: label: docker, or node (‘docker’) in it, but no agent with the label docker.

pinging @MarkEWaite to take a look, but I’m guessing its the scripted examples that are causing the confusion.

We need to improve that tutorial. We’ve received several comments that the steps are unclear and imprecise for a successful use of the tutorial.

I’ve opened a GitHub issue to track the improvements needed in that tutorial.