All Pipeline Jobs Fail After Jenkins Update

Hello all!

My organization just updated our Jenkins instance and are now seeing problems with our pipeline jobs. All of our declarative pipeline jobs now just stop at the “[Pipeline] Start of Pipeline” and will hang there indefinitely (see screenshot below)

When looking at what the job is doing in terms of the executors, it seems to be just sitting idily on the controller node and not even in the build queue. We have 4 executors on the build in node.

Does anyone have any troubleshooting steps we could try? We tried downgrading relevant pipeline plugins but that did not seem to work. Have also tried looking at logs but am unsure if I have found any relevant information. If anyone needs more context, info, I’d be happy to provide it. I just don’t know where to even begin with troubleshooting this problem

Background Info: We are running our Jenkins instance on Windows Server 2012 on premises. Our recent update was to 2.362.2. I can’t remember exactly the version number we updated from, but is was over 2 years old

I’ve seen behavior like that when my Jenkins controller started without a complete set of working plugins.

Be sure that the Pipeline plugins are installed, enabled, and not showing warning messages in the plugin manager. If you did a two year upgrade jump, then you should review the upgrades guides for the releases in the two years of upgrades that you skipped.