SMTP Email Not Sending Due To Wrong User

I am getting this error when trying to send a post build email.

protocolConnect returning false,, user=ALMPAV15$, password=

Where is it pulling this username and password from?

My configuration is set up correctly in the Email plug-in and when I send a test email from there it works.

This is full debug information:

Hello @msharoff and welcome to this community :wave:

Are you using the mailer plugin or the email extension plugin?
I guess if you haven’t configured anything regarding the user sending the mail, the user could maybe be extracted from System Admin e-mail address configured in Jenkins?

Email extension plugin

1 Like

Strange. What is your System Admin e-mail address configured in Jenkins?

I have my email address there. This section, correct?

1 Like

The username it is using is the name of my server that Jenkins is running on.

1 Like

It’s the same bug for me!
Is there a solution?

Randomly I found out, that the list of systems credentials for smtp authentication (a drop down list) is handled in a reverse way. If I want the first entry of the list I have to pick the last entry. Very strange.

If i choose system scope credential, email-ext show me password=<null> but if i change to global scope credential then password=<non-null>

My credentials are reported as not being used, even though I have very explicitly specified it. I have tried credentials with every possible scope and domain.

This is failing for both the standard email plugin and the extended email plugin.

It all worked smoothly 4 years or so ago when Jenkins was first set up. then it was disabled for several years and so I am having to set it all up again, and of course it is a newer and broken version now.

Any solutions found this issue?
Please post the solution if anyone got. Thanks in advance.