Question about updating Jenkins - all my jobs and info disappeared

Hello, I am hoping someone more knowledgeable than me can answer this. I want to update our Jenkins from a year-old version to the most recent. I downloaded the .war and tried to run it and it failed to launch. I posted here about that and someone kindly informed me that the newer versions require Java 11.

So I installed Java 11 and ran with the new .war, and it does launch. But all my jobs are gone, it acts like a new install! I nearly had a heart attack, but fortunately I had backed the whole jenkins_home folder before doing this and was able to go back.

So any idea why all my jobs would disappear when I attempt to update?

sounds like the JENKINS_HOME env variable isn’t pointed to the same place.

How did you upgrade? how are you running it?

The only thing I did was replace jenkins.war with the new version. And then to start Jenkins I have a batch file which sets JENKINS_HOME. So it should be pointing to the same place it was before. Then the batch file starts Jenkins, like this:

java -jar jenkins.war --httpPort=8081

sorry it’s not showing the slashes in that path, but in the script it’s correct

What OS (operating system) are you working on ?
What exactly was the previous “a year-old” version of Jenkins and which one do you want to go to now ?
How was it already installed on your system ?

Btw, I’m not sure that just replacing the .war file is the right way.

Other references :

Thanks for the reply - when I tried again it worked the second time. I am not sure what happened the first time.


Thanks for your feedback @sabibo :pray: .