Jenkins.io search

What content is currently indexed in our jenkins.io search?

I tried to find a blog post but it looks like these posts are not part of the index. Then I also tried to find some top level pages without success as well. E.g., I tried “UI”, “gsoc”, “Hafner”, “governance” without any results that I would have expected (only some developer resources).

1 Like

Yea I was noticing that too the other day when I was looking for something.

Looks like according to docsearch-configs/jenkins.json at 7b80777102fab1ac76dd2efa31f4714961902e1d · algolia/docsearch-configs · GitHub only /doc is indexed, which may not be the best?

@MarkEWaite do you know if it was just for the initial setup to exclude blogs and other things? What was the plan?

@olblak According to my original email, only you and @MarkEWaite have access to the jenkins.io interface? Can I get access as well? do you want a ticket?

1 Like

Which interface are you talking about? Algolia?

@olblak I think so? Wasn’t sure doc search had its own interface. Just need access to the project I guess?

Maybe @MarkEWaite can help, I only see the application plugins.jenkinse.io which you already have access

Based on the description of the Algolia docsearch product at https://docsearch.algolia.com/ , I think that we don’t have any facility to configure docsearch for www.jenkins.io. We’re using their free service. It indexes the /doc/ subtree.

I think you can reach out to them. The JSON file I linked has it set to /docs if we want more we’ll have to get them to change it

Update - Mark and I reached out to algolia support:

After a few emails back and forth we got the following info, but i won’t be able to poke at it for at least 2 weeks.

me:

Do we just change docsearch-configs/jenkins.json at 1789da957de6b5f75c2aa56a5ee76b1e8b63c266 · algolia/docsearch-configs · GitHub so its jenkins.io/ instead of jenkins.io/doc/? Or do we add like /blog/ and /projects/ under a different tag?

Algolia:

Hey Gavin,

I’ve heard back from the DocSearch team, and have been told that If you would like to extend the page to your whole website, you can remove the /doc at the end of the URL line: docsearch-configs/jenkins.json at 1789da957de6b5f75c2aa56a5ee76b1e8b63c266 · algolia/docsearch-configs · GitHub. Also, if you only want like to add the blog , you can add a new “block” in the start_urls .

Alternatively, here’s a PR that’s been created that you can answer directly on, which may prove to be easier: fix(jenkins): update config by shortcuts · Pull Request #4746 · algolia/docsearch-configs · GitHub

If you have any questions, please let me know!

Best,

1 Like

Thanks! I’ve confirmed that blog posts are now indexed by the search engine along with events like the contributor summit.