Generate Declarative Directive Button does not work

  1. Use the tool from a pipeline.
  2. Select Declarative Director Generator
  3. Select a sample directive
  4. press Generate Declarative Directive.
  5. No output. No errors thrown either.

I can’t duplicate that failure. Steps that I tried include:

  1. Start Jenkins 2.426.2 from the war file on Linux
  2. Choose the setup wizard path that allows me to choose components
  3. Choose Pipeline and Git and a few others
  4. Let the install complete, confirm that a declarative Pipeline works as expected
  5. Uninstall the declarative Pipeline plugins and restart Jenkins
  6. Confirm the declarative Pipeline menu selections are no longer available

As a wild guess, you might check that you’ve installed all the plugins that are required for declarative Pipeline. The key plugin is “Pipeline: Declarative”

I will look through dependencies one by one.

After installing all the dependencies and updating [“Pipeline: Declarative”] it worked. Thank you.