Access Denied xxxx is missing the Global/Read permission

Jenkins setup: jenkins 2.319.1

Hi everyone,

I’m having an issue with my Jenkins account, when I log in I see the following message :
Access Denied
XXXXXXXX is missing the Global/Read permission

The strange thing is that when my account was first set up it worked fine for a few weeks and then for no reason it stopped working.

I have already checked the usual answers to this topic and checked my account permissions with my admins. It seems that my permissions are set up correctly and according to the settings I should be able to see things. The security system we use is matrix based and my account has read permission checked.

We’ve also tried deleting and recreating the account and it hasn’t worked.

Do you have any idea or hints of what the problem might be ?

I was thinking that maybe there is a maximum number of users on Jenkins and we have reached it, so any new account is denied access, but that would be odd as I can’t find any information about this kind of restriction anywhere.

Don’t hesitate to ask me for details if needed, and thanks in advance for your help !