Workspace got deleted

Workspace got deleted automatically if it’s unused more than 30 days. How can I disable this for all jobs? Because we need to keep workspace permanently.

Hello @akhiljohn and welcome to this community :wave:

By any chance, are you using a cloud platform to host Jenkins?

Thanks @poddingue
I’m not using any cloud platform. Running on docker in centos 7 host machine. Also not using any plugins to cleanup workspace.
I tried below in script console
System.setProperty(‘hudson.model.WorkspaceCleanupThread.disabled’, ‘true’)

not sure it will effect or not. Waiting for a job which unused more than 30 days.

1 Like

What is the version of Jenkins and Docker you’re using?
Do you plan on upgrading to a more recent Linux distro?

Jenkins 2.332.2
Right now we don’t need to upgrade. Will it resolve on latest version?

@poddingue It’s not worked. Got deleted workspace which unused more than 30 days on last day.
Can you provide a solution for this?

I’m afraid I can’t. :person_shrugging:

Hopefully, somebody more knowledgeable will chime in.