New user running k8s: cannot access login URL


I’m using Jenkins for the first time running it in minikube. I followed this guide verbatim, generated an admin password and got my login URL.

When I go to the URL it doesn’t load saying it cannot be reached. Tried just accessing the URL without the login path and still no luck. Because its running in k8s is there any sort of port forwarding that needs to be done to be able to view the URL in my browser?

Can provide any info needed but if someone could help me out it would be much appreciated

Basic k8s debugging:
Is the pod running (kubectl get pods)
Is there anything in the error log? (kubectl logs $podname)
Are you connecting via ingress url? (kubectl get ingress) If so, does the ingress resolve to the right place?
If not ingress, is your service setup to allow outside traffic (loadbalancer, nodeport… pretty much anything but clusterip)


I’ll give this a go, im very basic with my k8s knowledge so basic debugging steps are very appreciated. thanks