Issues with Snippet Generator in Jenkins 2.440.2 after Update

Hello everyone,

After updating Jenkins to version 2.440.2 and all our plugins to their latest versions, we have encountered issues with the Snippet Generator in Jenkins. Previously, everything worked fine, but now several plugins seem incompatible with the Snippet Generator.

Here are some examples of the issues we are encountering:
Acunetix360Scan:
step object of type com.acunetix.plugin.ACXScanBuilder
XrayScan:
no public field ‘serverId’ (or getter method) found in class org.jfrog.hudson.pipeline.declarative.steps.xray.XrayScanStep
updateReleaseBundle:
no public field ‘name’ (or getter method) found in class org.jfrog.hudson.pipeline.scripted.steps.distribution.UpdateReleaseBundleStep

These are just a few examples of the plugins with which the Snippet Generator is failing. Before the update, everything worked smoothly.

Has anyone else experienced these issues after updating Jenkins and plugins? Are there any known solutions or workarounds for these problems?

Thank you in advance for any help or suggestions.

Best regards,
Walter

Hello everyone,

I have been investigating and reading in various posts that the issue might stem from the reverse proxy configuration. However, I performed a test with a Docker setup without a proxy and it didn’t work either. Additionally, I installed the plugins cleanly but still couldn’t get it to work.

Could it be a Jenkins problem? Does anyone know if the pipeline plugins are reporting any recent issues?

Any help or suggestions would be greatly appreciated.

Thank you in advance.

Hello and welcome to this community, @walterh. :wave:

You may want to get in touch with some of the plugin maintainers (via an issue) for the plugins that don’t work anymore with the snippet generator. :person_shrugging: