Failed to upgrade or install any plugins on Jenkins version 2.303.1

I’m using Jenkins version [2.303.1], and once I want to upgrade or install any plugin I got error like this for example: Downloaded file /var/lib/jenkins/plugins/okhttp-api.jpi.tmp does not match expected SHA-256, expected ‘jyA4GfzLkh3HFEtjDDXuopy2KGlgWHM3KuZyYbhPBKQ=’, actual ‘47DEQpj8HBSa+/TImW+5JCeuQeRkm5NMpJWZG3hSuFU=’
at hudson.model.UpdateCenter.throwVerificationFailure(
at hudson.model.UpdateCenter.verifyChecksums(
at hudson.model.UpdateCenter$InstallationJob.replace(
at hudson.model.UpdateCenter$UpdateCenterConfiguration.install(
at hudson.model.UpdateCenter$DownloadJob._run(
at hudson.model.UpdateCenter$InstallationJob._run(
at hudson.model.UpdateCenter$
at java.base/java.util.concurrent.Executors$
at java.base/
at hudson.remoting.AtmostOneThreadExecutor$
at java.base/

I’ve check network connectivity to update center url and there is, and tried also to restart Jenkins and still got this error.
maybe I want to upgrade Jenkins version?
Is there any solution for that?


That’s a surprising error message, especially because I don’t find either of those SHA 256 values in the list of okhttp plugin releases. I assumed that you were trying to download 4.9.3-108.v0feda04578cf since versions after that require Jenkins 2.361.4 or newer.

The mirrorlist shows that 7 mirrors have that file available. I downloaded that file from each of those 7 mirrors and confirmed that they are the same file on each of the mirrors. Check your network infrastructure to confirm that nothing is damaging the data transfer between your Jenkins controller and the Jenkins mirror that is used for your site.

I’m using the default update url site: , and there is no issue with the connectivity, by the way most of the plugins have warning like this:Warning: This plugin has dependencies on other plugins that require Jenkins 2.319.3 or newer. Jenkins will refuse to load the dependencies requiring a newer version of Jenkins, and in turn loading this plugin will fail.
and for okhttp I have warning like this : ** A newer version than being offered for installation exists (version 4.10.0-132.v7a_7b_91cef39c), so the latest bug fixes or features are not available to you. This is typically the case when plugin requirements, e.g. a recent version of Jenkins, are not satisfied. If you are using the latest version of Jenkins offered to you, this plugin release may not be available to your release line yet. See the plugin documentation for information about its requirements.**
I think I got that error because the version of Jenkins very old and I want to make sure that the issue with Jenkins version before upgrading it.

Yes, that message is reported because your Jenkins controller is so old that the update center no longer supports it. You’re missing several security fixes and many other valuable changes by not regularly upgrading your Jenkins controller.

So, to go ahead and upgrade Jenkins version to latest version and on this way will fix that issue with upgrade or install plugins? and by the way I can use the default update center url yes?