Plugin update KO after upgrade from 2.277.4 to last version (2.332.2)

hello,

Using 2.277.4 I configured the proxy of jenkins using my company proxy (no login) and it worked using following jenkins plugin website :

updates.jenkins.io/update-center.json

I removed the “s” of https, and also I installed skipcertificate because if jenkins was able to check new version availability, the download always failed.
With these modification I was able to do plugin update using 2.332.2 version.

After 2.332.2 update, I can still check for update but this time download always failed with same error message :

java.net.HttpRetryException: Invalid response code (407) from URL: http://updates.jenkins.io/current/update-center.json?uctest

I tried with:
updates.jenkins.io/current/update-center.json
updates.jenkins.io/update-center.json

with https or http.

the only stuff that is working is installing plugin providing the link of the plugin but it is painfull because we must install each dependency this manually (providing link or .hpi/.jpi file)

but always same error message.

is there something new about plugin update between 2.277.4 and 2.332.2 ?

thanks a lot

[edit] edit to be un-hidden, what is the problem with my post ?

I got some other error messages after providing different .json adresses to get plugin:

java.io.IOException: Server returned HTTP response code: 401 for URL: https://updates.jenkins.io/download/plugins/ant/1.13/ant.hpi

java.net.HttpRetryException: Invalid response code (401) from URL: https://updates.jenkins.io/update-center.json ?uctest

but no success

but if I provide https://updates.jenkins.io/download/plugins/ant/1.13/ant.hpi
as a link to install the plugin in “advanced”, it will work… I don’t understand !

407 means you have to log in to your corporate proxy.

Where exactly did you enter this URL?

I would ask people supporting your proxy to tell you what is wrong.

nowhere. I select the plugin and choose install and jenkins find itself this address.

1 Like

My recommendation would be first to fix the authentication problem - either via logging in or using some other proxy that does not require authentication.

After this we can look if 401 comes back.