Errors when attempting to download plugins happening at after redirect

We are currently working on moving our Jenkins setup from a server to a docker, and currently the problem is when attempting to install plugins we get connection errors. We have tried to identify if it is a network problem on our side but we cannot find a problem with our own networking.

We are using the docker image for jenkins/jenkins:2.426.2-lts-jdk17. Other than allowing some ports to be accessed via the host (80:8080 and 50000:50000) and pointing mapping a volume for the /var/jenkins_home data we’ve not made any changes.
What we see inside Jenkins is

Caused: Failed to download from <URL REMOVED>/download/plugins/audit-trail/361.v82cde86c784e/audit-trail.hpi (redirected to:
	at hudson.model.UpdateCenter$
	at hudson.model.UpdateCenter$DownloadJob._run(
	at hudson.model.UpdateCenter$InstallationJob._run(
	at hudson.model.UpdateCenter$
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at hudson.remoting.AtmostOneThreadExecutor$
	at java.base/

So we tried to make tests using curl from inside the docker. Our tests seem to find that during the redirect from updates[DOT]jenkins[DOT]io to get[DOT]jenkins[DOT]io something hangs.

Had to remove our CURL tests because you do not allow links and that is part of the code I need to post.

We’re not sure what is going on here, but it seems that there is a missing TLS handshake from get[DOT]jenkins[DOT]io. Again this only happens within the docker. When we attempt it from the host server we see a successful response:

Had to remove our CURL tests because you do not allow links and that is part of the code I need to post.

From the many results on line when someone searches for jenkins docker and plugin update failures it seems this happens a lot for lots of different reasons, none of which match our needs.

Hello @j.reed_cartago and welcome to this community. :wave:

I have experienced quite often issues when I build Docker images and I try to install or update plugins.
The website sometimes takes time to answer correctly… but in the end, after several attempts, it works.
What is the host of your Docker container? What are the settings in term of security on your machine when it comes to using Docker?