Installing suggested Plugins in Jenkins fails due to connection timed out

Hi everyone! I’ve been having some issues recently when trying to use Jenkins.
The problem is at follows:
A couple days ago while I was a the office I installed Jenkins using the official docker image (jenkins/jenkins:lts-jdk-17), installed the plugins and started working.
Later on, at my home, when I tried to use Jenkins again on my computer, whenever it tried to install the suggested plugins it just fails, resulting in installing just a few of them (almost never the same plugins when trying again).
Long story short, the problem it seems to be that whenever Jenkins is trying to install the plugin from I get a timed out connection, but when it tries to install it from everything works as expected.
I observed that from looking at the logs Jenkins creates when trying to install the Plugins and i also got inside the Docker container running Jenkins and I tried some curl commands. Also, when I connect my home PC to my phone hotspot, the problem disappears, so it seems that somehow I think that my IP is banned by, although I don’t understand why, cause it is the first time trying do install Jenkins on my computer within this network, which is a home network, not a public one.
Any ideas about what should I do in order to resolve this problem?
I will also leave some of the logs here so it may be more clear to everybody reading the topic:

2024-02-18 08:13:17.755+0000 [id=102]	SEVERE	h.model.UpdateCenter$DownloadJob#run: Failed to install cloudbees-folder Connect timed out
Caused: Failed to download from (redirected to:
	at hudson.model.UpdateCenter$
	at hudson.model.UpdateCenter$DownloadJob._run(
	at hudson.model.UpdateCenter$InstallationJob._run(
	at hudson.model.UpdateCenter$
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at hudson.remoting.AtmostOneThreadExecutor$
	at java.base/

Jenkins setup:
Jenkins: 2.426.3
OS: Linux - 6.1.0-18-amd64
Java: 17.0.9 - Eclipse Adoptium (OpenJDK 64-Bit Server VM)


Hello @helx, could you open an help desk issue at Issues · jenkins-infra/helpdesk · GitHub please?

1 Like

I will leave this here for everyone having the same problem.
I wanted today to open a ticket and I observed that someone else had already done that about 5 days ago and it seems that I am not the only one facing this problem. It seems that halifax has blocked the ISP in my country (Romania), RCS-RDS, so we need to install the plugins manually or use another ISP in order to install them.
Anyway, @hlemeur thanks for your reply and suggestion!

1 Like