After upgrading to 2.440.1, can't connect node without secret parameter


After upgrading Jenkins to 2.440.1, it seems I can’t figure out how to remove the secret parameter when connecting nodes to the controller. Previously you used to be able to give Agent-Connect permissions to the Anonymous user and that would allow you to make the node connection without the secret parameter, but that’s not working with 2.440.1.

I know the jnlpUrl parameter has been removed in favor of url, and I’ve updated to that but seems secret is now required.

Is that an intentional change or is it a bug? I didn’t see any documentation mentioning this.

I have a Jenkins controller with hundreds of nodes connected to it, and I don’t really want to manually update all those connections to include a unique secret hash for each.

Any help or info would be greatly appreciated, thanks!

I think Unify two entrypoints by basil · Pull Request #677 · jenkinsci/remoting · GitHub made the secret a requirement

Thanks. Was that intentional? I don’t see anything in the documentation saying it’s now required.

Any update on this?

I looked again and didn’t see any mention of this change in the changelog, so I’d suspect it’ll cause issues for anyone like myself who is currently able to remove the secret parameter.

The only thing I could find regarding this issue was this:

So I guess it was intentional instead of a bug?

It’s going to make managing Jenkins with hundreds of nodes a lot more complicated and more work.