Windows Script works when Using cmd. However fails when envoked through Jenkins?

I am running an IAR IDE build script to build an example file. When I run it locally through a Windows “cmd” screen, it evokes IAR IDE and does a build successfully. However, when I run the same script through Jenkins I get an error message, as follows:

The unknown argument variable “${CMSIS_PACK_PATH_Maxim#MAX32670#1.0.3}$” was encountered while loading the project “C:\IAR_Examples\MAX32670_Example_TEST\DMA\IAR\DMA.ewp”.

The above path is where the pack gets installed. Has anyone encountered anything similar where the script runs fine in Windows “cmd” screen, but fails when evoked through Jenkins?

Also, this may not be related, but the complete error message was as follows with the SLF4J: in both cases (i.e. in Windows Cmd screen and Jenkins). However the one that I ran through cmd did not complain about the $(CMSIS_PACK_PATH… and built successfully.

SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See SLF4J Error Codes for further details.
The unknown argument variable “${CMSIS_PACK_PATH_Maxim#MAX32670#1.0.3}$” was encountered while loading the project “C:\IAR_Examples\MAX32670_Example_TEST\DMA\IAR\DMA.ewp”.

Thank you all in advance. Please let me know if you need any additional information.


Hello @ftariqtx and welcome to this community :wave:

What is the agent you’re using? The default one on your controller, another one on the same machine, another one on another machine?
Is it through Docker?
Are the command line tests done on the same machine as the Jenkins build?


Hello Bruno,

Thank you for the welcome and thank you very much for responding back. It is truly appreciated. I am very new to Jenkins, so pardon my ignorance and please do ask for clarifications. I will try to explain

So there is a master that runs the Jenkins and is on a separate computer. I have a Node/Slave that hosts the Job (I wrote the Job) for running the script. So I ran the script on the Node/Slave machine via the Windows “cmd”, which it runs successfully and then I run the same script on the same Node but triggered by the Jenkins Job and it fails there. Hopefully it answers your query.

I am not sure if I follow your question: “what is the agent” I am using? I have written a Job to run on the Node/Slave machine, does this answer your question?

I am not running this through Docker.



1 Like

Hello Faisal,

Thanks for your kind message. You don’t have to apologize for being new to Jenkins, we all have to start somewhere, and I’m fairly new too.
By “what is the agent?” I was meaning what you call the node/slave, so that you answered my question.
By the way, we don’t call agents nodes or slaves anymore (was nodes ever used, I’m not sure?), we’re now using more inclusive naming like agent and controller.

Now that we’ve ruled out the most obvious causes, let’s hope someone more knowledgeable will come along and tell us.

Thank you Bruno for your effort.

1 Like