Not sure I understand what you’re after. If you select this provider, Jenkins will compute and use the list of people that contributed to the changeset that is being built, so there is no additional parameter to provide.
I couldn’t find an example anywhere with this design [[$class: ‘DevelopersRecipientProvider’]]
recipientProviders: [developers()] is exactly the same as recipientProviders: [[$class: 'DevelopersRecipientProvider']]. The developers() part refers to the exact same class (through the @Symbol("developers") annotation on the DescriptorImpl inner class).
I’m not sure where your original snippet came from, but I’m guessing that it was probably generated from an older version of the plugin which may not have had symbol support. Without the @Symbol("developers") annotation on the inner class, the initial way you were asking about would have been the only way to add the developers recipient provider to the email. However, now with that annotation there, developers() is the preferred way and is much easier to read and understand.