Post build not running

hi all,
i have a problem that start around 2 weeks ago.
when i run the POST Build it failed but when i run it Manually it work.
i even try to create a new POST that only copy txt file to my Sheard folder with out any success.

this is the batch command :
echo %BUILD_TAG%
echo GIS

echo test > test.txt
dir \itnas\managix
xcopy test.txt \itnas\Managix\text.txt /E /Y /I

this is the console output
Started by user Jenkins Admin Building on master in workspace C:\Jenkins\workspace\temp_test [WS-CLEANUP] Deleting project workspace… [WS-CLEANUP] Done [temp_test] $ cmd /c call C:\Users\JENKIN~1.ADM\AppData\Local\Temp\hudson4481171873961108583.bat C:\Jenkins\workspace\temp_test>echo jenkins-temp_test-10 jenkins-temp_test-10 C:\Jenkins\workspace\temp_test>echo GIS GIS C:\Jenkins\workspace\temp_test>echo test 1>test.txt C:\Jenkins\workspace\temp_test>dir \itnas\managix The referenced account is currently locked out and may not be logged on to. C:\Jenkins\workspace\temp_test>xcopy test.txt \itnas\Managix\text.txt /E /Y /I Invalid drive specification 0 File(s) copied C:\Jenkins\workspace\temp_test>exit 4 Build step ‘Execute Windows batch command’ marked build as failure Finished: FAILURE

I don’t know much windows stuff but isn’t that the error there?

I know the error is there, the issue is that when the post build run it failed ( with the Xcopy command )

The batch command is : (Part of it)

echo %BUILD_TAG%

echo GIS

xcopy S\Sources\Server\SMNG.Server.Geo\Services\GISServer\Web \itnas\Managix\Jenkins\Trunk\Server%BUILD_DISPLAY_NAME%\SMNG\GISServer\Web /E /Y /I

The Console Output :

C:\Jenkins\workspace\Trunk_Server_Post>xcopy S\Sources\Server\SMNG.Server.Geo\Services\GISServer\Web \itnas\Managix\Jenkins\Trunk\Server#673\SMNG\GISServer\Web /E /Y /I

Invalid drive specification

0 File(s) copied

When I run the Xcopy command without the S it running….


That seems to be the first error. The account is locked at the “itnas” server (if it is a local account there) or at the domain controller (if it is a domain account). Might be caused by too many failed login attempts with incorrect passwords.