Plugin installation failed

I have installed Jenkins and plugins on a VM in cloud. Then I migrated all the jobs using thin backup plugin. Now I see error in some plugins as mentioned below:

Could you please tell what might be the reason and how can I install them?

Apache HttpComponents Client 4.x API

Cycle detected: Plugin:jdk-tool → Plugin:apache-httpcomponents-client-4-api → Plugin:jdk-tool

Build Failure Analyzer

Failed to load: Build Failure Analyzer (build-failure-analyzer 2.0.0) - Required plugin is disabled: Jenkins Apache HttpComponents Client 4.x API Plugin (apache-httpcomponents-client-4-api)

Build Pipeline Plugin

Failed to load: Build Pipeline Plugin (build-pipeline-plugin 1.5.8) - Failed to load: Jenkins Parameterized Trigger plugin (parameterized-trigger 2.45)

Have you updated all plugins to latest version?

Hi, do you mean updating for example:
Apache HttpComponents Client 4.x API
Apache HttpComponents Client 5.x APIVersion5.2.1-1.0

If its the case do I need to manually search for latest version of each plugin and install it? Because I don’t see any upgrade button beside Apache HttpComponents Client 4.x API.

Please also kindly let me know if I need to get Apache installed for those plugins.


Go to <jenkins>/manage/pluginManager/ and check if there are any plugins that need to be updated.
Look especially for the 2 plugins in the cycle apache-httpcomponents-client-4-api and Oracle Java SE Development Kit Installer (this is the jdk-tool plugin)
Also check if you really need the Oracle Installer, you only need it when you need to provide the Oracle jdk as a tool for your builds. If not the try to uninstall it (this might not work when you have plugins that are built for an older version of Jenkins core)

Hi thanks for the reply. yes we have oracle installed as all the jobs are based on Oracle. My current installed plugins page looks like below:

I was wondering why I don’t see a upgrade button beside the plugin. and deos these plugins need apache Tomcat installed on my machine?

You’re at the installed plugins page. On left you should see Updates check if there is anything
Also check if the update site url at <jenkins>/manage/pluginManager/advanced is correctly configured and points to
Which version of Jenkins are you using?

and btw you have a message saying that you should restart Jenkins. I would first do so before updating plugins

I’m using [Jenkins 2.387.3]. Because the same version was being used on On-Prem server.

Inorder to install Jenkins JSch dependency plugin it is asking to update Trilead API plugin.
Unfortunately I see below message:

Does this mean I need to install new version of Jenkins on the new Server. Please let me know if there is any solution how I can recover and run my jobs without upgrading it new version of Jenkins?

Those are warnings that the trilead plugin has an incompatible change. Normally this is not a problem but means when you need to roll back you need to do manual changes (or recover from a backup)

best is to update all plugins and then restart.

1 Like

Thank you so much I updated all the required plugins.


I tried to start slave agent on new Jenkins server and I’m gettint following error: ( May slave agent has Java 8 version and Jenkins Server has Java 11. On my old Jenkins Server I never had such problem although I have same Java version on old and new servers)

Starting agent process: cd “/gg/Jenkins_Rt” && /usr/bin/java -jar remoting.jar -workDir gg/Jenkins_Rt -jar-cache /gg/Jenkins_Rt/remoting/jarCache
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: hudson/remoting/Launcher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at sun.launcher.LauncherHelper.checkAndLoadMain(

Please guide me how I can I proceed.


Upgrade the agent to use java 11. Java 11 has been recommended for awhile now.

1 Like

Hi, thanks for replying. it works.

After migrating my jobs to new jenkins instance, I ran few jobs and I don’t see the build process. I mean I’m not able to see either previous builds or present build in build history:


In old instance it was like below:

It was easy for me then to click on present build and get into its console to look at the process. Please let me know if need to confgure anything else?