Job Import Plugin doesn't import folder

Hi all.

I’m currently trying to import jobs from a server running on AWS to a new server running on GCP Kubernetes.

I already set up the Job Import Plugin version 3.4 on the new server.
When I tried to import the jobs it worked when it was only 1 job.
But when I imported a Folder with jobs and folders inside, the Folder is imported with nothing inside.

Old Server: Jenkins version 2.127
New Server: Jenkins version 2.289.2

Any help?

:wave: I don’t know if I’ll be able to help too much as I’ve never even heard of that plugin let alone used it, but what does the plugin do that copying the config.xml file from disk from one server to the other doesn’t do? Is it just the UI factor?

This question was cross-posted by @jbacelo to StakcOverflow

I’d like to think I provided an explanation of the problem and workaround (which has been marked as answered), until such time as the issues in the plugin are fixed:
JENKINS-53902 - Jobs in folders are not copied from Remote Instance
JENKINS-64121 - Error ‘/’ unsafe character
And the documentation updated with this basic usage explanation and however jobs in folders are handled going forward.

The TL;DR is the plugin just handle a folder same as a freestyle or pipeline job, both Job items that are copied. It does not recursively handle the nested jobs properly.