Jenkins took some agents offline because their key health metrics went below a threshold

Hi, Post upgrading Jenkins LTS to latest(2.426.1) all of the jobs getting queued. I can can see " Jenkins took some agents offline because [their key health metrics] went below a threshold. If you don’t want Jenkins to do this, [change the setting]" notification. Does this new version changed my configurations. My Jenkins deployed/upgraded using Helm on K8s cluster>FYI. Please advise.

After upgrading Jenkins LTS to 2.426.1, I could see Kubernetes agents getting keep offline, hence jobs not getting able to pick any agents and queued up. Please suggest to fix this.

What is the configuration of your node monitors (…/computer/configure)? Maybe your agents have not enough diskspace thus they are taken offline. Those settings haven’t changed.

Jenkins disk space also looks fine

I observed that only cloud agents(from kubernetes plugin) gets provisioned and terminating automatically without tied to any of the jobs. Need advise if this happened to latest LTS 2.426.1?

I am assuming that issue with Remoting version in my Jenkins. I found the below remoting version in my Jenkins


Does this the cause the issue? how to upgrade remoting version to 4.13 using helm on Kubernetes cluster.

Minimum required Remoting version updated to 4.13

The minimum required Remoting version has been increased to 4.13, which was released on March 4, 2022. When an agent with a Remoting version older than 4.13 connects to the Jenkins controller, the agent connection is rejected. Ensure that all agents are running a recent version of Remoting prior to upgrading. Agents with unsupported Remoting versions can be allowed to connect to the controller by setting the hudson.slaves.SlaveComputer.allowUnsupportedRemotingVersions system property to true.

I don’t use kubernetes, so I don’t know how this works, but if the agent.jar is built into a docker image then maybe you need to update the docker image to use the agent.jar that fits to your jenkins version.