Jenkins stuck on "Please wait while Jenkins is getting ready to work" page during installation on Windows

I tried to install Jenkins on windows but Jenkins was stuck on “Please wait while Jenkins is getting ready to work” page during installation. It is not moving to Unlock Jenkins screen.

Can you check the logs in C:\Program Files\Jenkins (there should be some .log files there).

I checked the log files, attached below. The windows machine has no internet access but at least it supposed to unlock the jenkins.

2023-05-11 14:24:40.972+0000 [id=1]	INFO	winstone.Logger#logInternal: Beginning extraction from war file
2023-05-11 14:24:46.176+0000 [id=1]	WARNING	o.e.j.s.handler.ContextHandler#setContextPath: Empty contextPath
2023-05-11 14:24:46.254+0000 [id=1]	INFO	org.eclipse.jetty.server.Server#doStart: jetty-10.0.13; built: 2022-12-07T20:13:20.134Z; git: 1c2636ea05c0ca8de1ffd6ca7f3a98ac084c766d; jvm 17.0.7+7
2023-05-11 14:24:50.457+0000 [id=1]	INFO	o.e.j.w.StandardDescriptorProcessor#visitServlet: NO JSP Support for /, did not find org.eclipse.jetty.jsp.JettyJspServlet
2023-05-11 14:24:50.536+0000 [id=1]	INFO	o.e.j.s.s.DefaultSessionIdManager#doStart: Session workerName=node0
2023-05-11 14:24:51.155+0000 [id=1]	INFO	hudson.WebAppMain#contextInitialized: Jenkins home directory: C:\data\jenkins_home found at: EnvVars.masterEnvVars.get("JENKINS_HOME")
2023-05-11 14:24:51.288+0000 [id=1]	INFO	o.e.j.s.handler.ContextHandler#doStart: Started w.@f1a45f8{Jenkins v2.387.2,/,file:///C:/tools/jenkins/war/,AVAILABLE}{C:\tools\jenkins\war}
2023-05-11 14:24:51.326+0000 [id=1]	INFO	o.e.j.server.AbstractConnector#doStart: Started ServerConnector@36b4091c{HTTP/1.1, (http/1.1)}{}
2023-05-11 14:24:51.336+0000 [id=1]	INFO	org.eclipse.jetty.server.Server#doStart: Started Server@416c58f5{STARTING}[10.0.13,sto=0] @11278ms
2023-05-11 14:24:51.336+0000 [id=27]	INFO	winstone.Logger#logInternal: Winstone Servlet Engine running: controlPort=disabled
2023-05-11 14:24:51.624+0000 [id=33]	INFO	jenkins.InitReactorRunner$1#onAttained: Started initialization
2023-05-11 14:24:51.625+0000 [id=38]	INFO	jenkins.InitReactorRunner$1#onAttained: Listed all plugins
2023-05-11 14:24:52.782+0000 [id=32]	INFO	jenkins.InitReactorRunner$1#onAttained: Prepared all plugins
2023-05-11 14:24:52.782+0000 [id=32]	INFO	jenkins.InitReactorRunner$1#onAttained: Started all plugins
2023-05-11 14:24:52.798+0000 [id=36]	INFO	jenkins.InitReactorRunner$1#onAttained: Augmented all extensions
2023-05-11 14:24:53.148+0000 [id=36]	INFO	jenkins.InitReactorRunner$1#onAttained: System config loaded
2023-05-11 14:24:53.148+0000 [id=36]	INFO	jenkins.InitReactorRunner$1#onAttained: System config adapted
2023-05-11 14:24:53.148+0000 [id=36]	INFO	jenkins.InitReactorRunner$1#onAttained: Loaded all jobs
2023-05-11 14:24:53.148+0000 [id=36]	INFO	jenkins.InitReactorRunner$1#onAttained: Configuration for all jobs updated
2023-05-11 14:24:53.340+0000 [id=51]	INFO	hudson.util.Retrier#start: Attempt #1 to do the action check updates server
2023-05-11 14:24:53.750+0000 [id=33]	INFO	jenkins.install.SetupWizard#init: 


Jenkins initial setup is required. An admin user has been created and a password generated.
Please use the following password to proceed to installation:


This may also be found at: C:\data\jenkins_home\secrets\initialAdminPassword


You say the UI only shows something about Jenkins getting ready? Can you share a screenshot?

Hi Alex,
url shows as http://localhost:8080/login?from=%2F
Here is the screenshot

Have you tried refreshing? The logs you showed mean that Jenkins should be fully up and running. What browser are you using?

I am using edge browser.

Can you try with Chrome or Firefox? I have never used Edge with Jenkins, I don’t remember where the browser support policy is, but I know Chrome and Firefox are supported.

edge is essentially chrome.

I don’t think it is related with driver.
Does Jenkins required to download and dependencies or plugins?
Do you have any idea?

Thank you

I changed the port to 8081 but still the same. Why java is working and listening the port but Jenkins does not start? Still stuck on “Please wait while Jenkins is getting ready to work”

I was trying to install Jenkins to a totally isolated environment, but Jenkins requires internet connection to certain domains to download the initial plugins.
Here is the list of the domain that you need an access at least for initial setup. It may change by region and I am located in East Coast

Thanks for all your sharings.