Jenkins SSL Configuration

Hi Guys,

I installed Jenkins and tried to configure SSL with .jks file, it didn’t work for me. Later is found that lower version 2.305 is compatible with this configuration. After installing 2.305, SSL/HTTPS works fine but there are issues with plugins.
Could anyone help with latest stable version which can be configured with SSL.

Thanks in advance.

  • Sachin Goel

Hello @goel_sachin and welcome to this community :wave:

Did you try the 2.375.1 LTS?
What is the OS you’re using?
What is your JDK?


Yes i tried 2.375.1 LTS.
OS - Window
JDK - 1.8.0_281


1 Like

This version doesn’t support Java 8. Is it possible you maybe didn’t properly configure the keystore for a Java 11 JDK?

1 Like

my bad… i used this for downgraded version - 2.330
for 2.375.1, i used jdk 11

I don’t have a Windows OS to test, but here are a few things that might help you get more answers from other folks:

  • double check and confirm the jks file is properly installed in the keystore of the jdk 11 (one mistake I can think ofcould be that you installed it for the jdk8 and forgot to reinstall it for the jdk11).
  • once you confirmed my first point, give more details to “it didn’t work for me”: what did you do? What do you observe (warning/error message in the logs maybe?).