Jenkins pipeline is failing intermittently with " JENKINS-48300: if on an extremely laggy filesystem "

Hi Team,

We have CloudBees Jenkins and intermittently we are getting below error in any stage of Jenkins pipeline job. Anybody have similar issues and if can help to fix it. We have Unix Jenkins agents.

(JENKINS-48300: if on an extremely laggy filesystem, consider -Dorg.jenkinsci.plugins.durabletask.BourneShellScript.HEARTBEAT_CHECK_INTERVAL=86400)

Thanks in advance.

If you have a product from CloudBees, then you’ll usually get the best answers by opening a question through the CloudBees support system.

There isn’t a product called “CloudBees Jenkins”, so I’m not sure what you have. If you have Jenkins, then it is not a CloudBees product. If you have CloudBees CI, then that is a CloudBees product and the CloudBees support team is your best choice.

That may mean your agents are running on a remote file system and the remote file system is heavily loaded. Either use a local file system (preferred) or increase the check interval with that setting.

You might also refer to the comment by @mawinter69 in Error: JENKINS-48300

You might also want to try out the binary wrapper.

This is not very well documented.

Start Jenkins with -D org.jenkinsci.plugins.durabletask.BourneShellScript.USE_BINARY_WRAPPER=true to enable it for the “sh” step

Instead of Jenkins start a shell script that starts the actual script and run every couple of seconds “touch” this uses a binary that do all this.

We’ve had the same issue on our machines that was caused by heavy load situations. We saw this issue usually several times a day (out of ~1500 builds), since we enabled the binary wrapper the problem disappeared.

The binary wrapper is not available on all Unix OS, but should be available for Linux on x86, ppc64le and arm64 architectures and macos on amd64 and arm64