Jenkins is not working after changing the port 8080 to 8443

Hi Team,

We are trying to change the Jenkins port from 8080 to 8443 to enable secure access. However, after making this change, Jenkins is down and not functioning. We are using IIS with an SSL certificate.

Could you please assist us with this issue.

Could you please suggest how to configure to https.

Jenkins.xml file

jenkins Jenkins This service runs Jenkins automation server. C:\Program Files\Microsoft\jdk-17.0.11.9-hotspot\bin\java.exe -Xrs -Xmx256m -Dhudson.lifecycle=hudson.lifecycle.WindowsServiceLifecycle -jar "C:\Program Files\Jenkins\jenkins.war" ----httpPort=-1 --httpsPort=8443 --httpsListenAddress=ITSEELM-NT8007.ikea.com - - webroot="%ProgramData%\Jenkins\war" rotate %ProgramData%\Jenkins\jenkins.pid 10000 false

Thanks and Regards,
Srini.

You’re telling Jenkins to use https but you’re not providing a keystore that contains the private key and the certificate.
Maybe you want IIS to terminate the ssl connection, then you will probably need to stay on an http port. But I have no clue how the setup would need to look in this case.

Hello Markus,

We are using reverse proxy in IIS to redirect HTTP URLs to HTTPS. However, after the redirection, it still listens on port 8080. Our main goal is to stop listening on port 8080. When we attempt to disable port 8080 in Jenkins.xml, Jenkins goes down. We’re not sure how to stop using port 8080.

If possible, Could you please guide me.

Thanks,
Srini.

If you are using IIS as a reverse proxy, that is where the https setup should be. You can leave Jenkins running on port 8080 and just add --httpListenAddress=127.0.0.1 to your Jenkins command line in jenkins.xml. This will now make Jenkins only listen on the localhost address and all of the SSL communication will be handled by IIS. You should set --httpPort=8080, remove --httpsPort=8443 --httpsListenAddress=ITSEELM-NT8007.ikea.com and set --httpListenAddress=127.0.0.1.

1 Like

Hello Alex,

I wanted to let you know that the issue is finally resolved and everything is working perfectly now. Your input was incredibly helpful. We had been stuck on this problem for many days, but thanks to your assistance, we were able to overcome it. Thank you so much for your support!

Thanks and Regards,
Srini.

Great, glad to hear it is working now!

1 Like

Hi Alex,

One small query, We would like to change our Jenkins URL from https://ITSEELM-NT8007.ikea.com to https://Jenkins.ikea.com. Is it possible to make this change.

If so, could you please share the steps to do so.

Your assistance would be greatly appreciated.

Thanks in advance.

go to global Jenkins config and change the url there. That’s all you should need to do assuming that the DNS already exists and points to the machine

1 Like