Jenkins HTTP Status 403-Forbidden Error

Hi Team,
I’m facing an issue with Jenkins while after adding users assign Global roles and Item roles and click save button i’m getting error
HTTP Status 403-Forbidden error.
Due to this error i’m unable to add new users and assign roles. Please help on this error. What is cause for this error…? How to fix this error.

seems you’re talking about role-strategy plugin.
Are you by chance removing admin permissions for your own user? When this happens locally I get presented a login screen though.

I recommend posting your logs (browser, Jenkins, whatever) cause all we can do is guess. Even reproduction steps would help.

I mean I asked for logs, and you gave me a screenshot of your browser.

In this case, the “No valid crumb was included in the request” is often caused by the browser accessing jenkins from a different url from the one in your configuration screen (or config.xml) or you have your reverse proxy setup wrong. Its hard to say with no information.

Hi halkeye,

Thanks for your reply.
Yes i tried for share the logs and I checked in Tomcat Catalina logs same error message there also but I couldn’t able to share those logs due to access issue. Sorry for that.

Note:- We don’t have configured any reverse proxy setup.

Is there any plugins issue…? When i googled somebody saying that deprecated and old version of plugins cause of this error. Is that true…?
Due to this error i couldn’t able to do any changes like(Adding new user in Item Role section, Global Role section.)

It absolutely could be be an issue. Especially after an upgrade of the controller. We always recommend upgrading.

Hi @halkeye ,

We have upgraded controller(Jenkins version to latest version 2.346.2 and plugins also we have upgraded. But few plugins are showing still warning and deprecated.) Is this cause for this error “No valid crumb was included in the request”. Please suggest on this issue.

The below plugins are showing warning:-

Date Parameter Plugin 0.0.4
Extended Choice Parameter Plug-In 346.vd87693c5a 86c
Dynamic Extended Choice Paramete Plug-In 1.0.1
Static Analysis Utilities 1.96
HTTP Request Plugin 1.16

I still recommend looking at your global configuration page and making sure your jenkins url matches the one in your browser. A mismatch usually generates the wrong cookies.

(post deleted by author)

One thing: The CSRF cookie has a limited lifetime, so check if all (host, client) clocks are set correctly.
It also can happen if you try to submit after the page has been open for too long.

(post deleted by author)