Jenkins Bitbucket Credentials Cannot read repo

I want to read the bitbucket repo from Jenkins throught git. I did provide the bitbucket url in Maven integration project and provide my username and password to it but unfortunately it cannot read the repo. I don’t know what wrong with it. Anyone can enlighten me.

The Error is
Failed to connect to repository : Command “C:\Program Files\Git\bin\git.exe ls-remote -h – HEAD” returned status code 128: stdout: stderr: fatal: Cannot prompt because user interactivity has been disabled. remote: Login failed due to incorrect login credentials or method. remote: If you are unsure of which login details or login method to use, visit: remote:

How to solve this error? I totally a beginner in jenkins. Please help me. A billion thanks for your help.

There is a description of Jenkins credentials on this page

That page also includes the video:

I had use the Jenkis credential helper which is username and password but still there is error pop out.

I tried with my personal github repo and it working perfectly but when I using company bitbucket repo it display error.

I had tried to create Bitbucket App Password but the option doesn’t display there.

May I know what wrong with it?

If you ever have access to the machine running Jenkins, open a command prompt or terminal and try running the failing Git command manually:

"C:\Program Files\Git\bin\git.exe" ls-remote -h -- HEAD

Is it failing?