Installed Jenkins plugin is not appear in Jenkins job configuration

Hi all,

Version → 2.386.3

I am using Jenkins in my local docker container. I am am trying to install Publish to Confluence plugin.
I have installed and I restarted Jenkins instance and I have checked is the library appear under Manage Jenkins → Manage Plugins → Installed. However When I create a Free Style job and go to Post Build Actions dropdown then I can’t see Publish to Confluence plugin exist.
I have also tried different versions of the plugin and installed via Advanced Settings → Deploy Plugin and deploy and restart Jenkins after successful installation message appear. When I check the logs from Jenkins I see the message is appear “Starting the installation of confluence-publisher on behalf of …” and “Downloading confluence-publisher” messages exist.
I have also tried with the latest Jenkins version which is 2.414.1 and I have the same result.

I have tried to upload versions of the plugin below and none of them worked.


I also cleaned cache in “var/jenkins_home/cache” directory and checked again nothing changed.

Have you configured the plugin? Without at least one site configured, the postbuild action will not be available it seems

Can you please give me more information about what to configure? I have added confluence credentials in Jenkins → Manage Jenkins → Credentials but I don’t understand what else to configure?

Have you followed what is described here:

In the global Jenkins config you need to add at least one site.

I understand what you mean now. Manage Jenkins → Configure System → Confluence / Confluence Sites. I am working on this right now thank you so much. I’ll post it here if I figure out.

Do you have any idea which information I should add in here?
I have created Credential with “Secret Text” and add “Created API Token”
Also created credentials like Confluence “username” and “password”
Also created credentials like Confluence “email” and “password”

I have following error