Getting Github integration plugins error while installing plugins

Please someone help me or provide steps how to resolve this below error. after installation I tried to install all the plugins but all plugins are failed with same below error.

JavaBeans Activation Framework (JAF) API
Failure - unable to find valid certification path to requested target

Hi there,

“it doesn’t work” is always hard to remote debug. Try to always include these 3 things.

  1. what did you try and what was the environment where you tried it? (Code samples, command lines, screenshots, videos, etc)
  2. what did happen? (Error messages, description, outputs, stuff)
  3. what did you expect to happen?

Otherwise, it’s hard for us to get into your context and you’ll have to have someone who is exactly knowledgeable come along.

In this case, if you’re on a Linux computer, you might be running an outdated operating system that does not include the most recent certificate authority (CA) updates. Update your operating system with the operating system package manager.

If you’re on a Windows computer or a Linux computer, you might be running an outdated version of Java. Be sure that you’re running a recent version of Java 11 (11.0.15), Java 17 (17.0.3), or for a little while longer, Java 8 (8u332).

You might be affected by a corporate network that rejects the Let’s Encrypt certificate that is used for the SSL certificate on . If that’s the case, then you’ll need to have the maintainers of the corporate network fix the issue.

1 Like