Jenkins sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I get this when trying to update plugins after updating to Jenkins 2.361.2. I see a lot of posts about this online, but many of the solutions are outdated. Is there an accepted way to fix this problem currently? I see things in this forum about java being outdated, but I think I have the latest version of OpenJDK 11.

OK I read that a common solution to this was to update java. I thought I had the latest java 11, but I found a later one and that fixed the problem. 11.0.2

1 Like

I assume that 11.0.2 was the version that has the problem, since it was released over 3 years ago. 11.0.16.1 is the current Java 11 version.