Freestyle: SVN checkout failing for overlapping jobs

Jenkins: 2.414.1

OS: Windows 10 - 10.0
Java: 11.0.19 - Eclipse Adoptium (OpenJDK 64-Bit Server VM)
Subversion Plug-inVersion2.17.3

Hoping someone might be able to point me in the right direction.

After recently upgrading our Jenkins version (was previously 2.187) on Windows 10 to 2.414 we’re running into what seems to be an issue with queueing for freestyle jobs.

The jobs folder from the working install was copied across to the upgraded install, no changes to scheduling has been made whatsoever.

It appears that if a job is scheduled to start while another job is still running, rather than wait for the current job to complete, the job tries to start and fails on SVN update

e.g. job A started at 20:35 17 Sept and Finished at 00:44 18 Sept
job B tried to start at 23:37 17 Sept and failed … extract from console output below

Started by timer
Running as SYSTEM
Building in workspace C:\Jenkins
Cleaning up C:\Jenkins.
Deleting C:\Jenkins\projects\CA78xx\CA6365-K7\vivado.jou
Deleting C:\Jenkins\projects\CA78xx\CA6365-K7\CAS7005
ERROR: Failed to update https://:/svn/PLD/trunk
org.tmatesoft.svn.core.SVNException: svn: E204900: Unknown error
at hudson.scm.subversion.UpdateWithCleanUpdater$TaskImpl$1.handleStatus(
at org.tmatesoft.svn.core.wc.SVNStatusClient$1.receive(

The job is set to “Emulate a clean checkout by first deleting unversioned/ignored files then svn update”

Any pointers greatly appreciated

*** Edit ***
I just manually started a job (#1851) then manually started another job (#'23) … I would have expected the second job to go onto the build queue, but instead Jenkins tries to execute it immediately. Since the checkout workspace is shared, all sorts of issues then arrise


Try enabling the ‘Do not allow concurrent builds’ option in the job configuration.

This is a source for all sorts of problems when you run things in the same folder. If you want to avoid this you need to make sure that concurrent builds can’t happen. As you have different projects running the same workspace it is not enough to just disallow concurrent builds of the projects itself. You will need the plugin Throttle Concurrent Builds and define global categories and then throttle all jobs via a category.
Did you maybe forget to copy certain config files from the old to the new Jenkins instance?

Thanks for the replies. I don’s see the option ‘Do not allow concurrent builds’ in the job config, perhaps because our jobs are freestyle and not pipeline?

Ill look at the Throttle Concurrent Builds plugin, sounds like that good work for us. Im pretty certain there wasn’t a plugin on our previous install pertaining to concurrent job management. It was quite old though. Could the default Jenkins behaviour have maybe changed between these versions (2.187 to 2.414) … probably not?!?