factDefinitions with "Office 365 Connector" not working anymore for multiline templates

I have been sending long time Teams notifications via “Office 365 Connector” plugin by using “factDefinitions” with multilines for Teams and not have had any issues. Anyway in some point of last week this thing stopped to work and multiline output has not been shown anymore.

I have tried both Office-365-Connector:4.18.0 and Office-365-Connector:4.17.0 but no difference between them.

So basically I have just sent line change as part of tempalate content for factDefinitions like in example below:

factDefinitions: [[name: "fact1", template: "content of fact1"],
                  [name: "fact2", template: "\n\n5.6.7.8"]]

As output in Teams notification there comes just like this:

UPDATE: Just realized that this issue happens only on desktop (windows and macOS) Teams clients, but e.g. in Android mobile app for Teams notifications are still shown as multilines.

Issue solved, looks that things works like previously in case of using <br> instead of \n

1 Like

Hello @jjaaskel and welcome to this community :wave: .

Thanks a lot for your feedback, I’m glad to see you solved it.

1 Like