Disk space below threshold

Hello everyone,
I am new to Jenkins and I have a problem.
I have created a cloud for amazon.
I have configured the ami to create the agents, but every time it is deployed I get “Disk space is below threshold of 1.00 GiB. Only 473.34 MiB out of 474.81 MiB left on /tmp.”
I have jenkins running on a docker image on ec2, which is a t2micro with 8GB.

If I do df -h on the ec2 containing docker I see no space problems.
Filesystem Size Used Avail Use% Mounted on
devtmpfs 4.0M 0 4.0M 0% /dev
tmpfs 475M 0 475M 0% /dev/shm
tmpfs 190M 3.0M 187M 2% /run
/dev/xvda1 8.0G 4.2G 3.8G 53% /
tmpfs 475M 0 475M 0% /tmp
/dev/xvda128 10M 1.3M 8.7M 13% /boot/efi
tmpfs 95M 0 95M 0% /run/user/1000

If I do the df -h on the agent, which is created, there are no space problems either.
Filesystem Size Used Avail Use% Mounted on
devtmpfs 4.0M 0 4.0M 0% /dev
tmpfs 475M 0 475M 0% /dev/shm
tmpfs 190M 2.9M 188M 2% /run
/dev/xvda1 8.0G 1.9G 6.2G 23% /
tmpfs 475M 1.5M 474M 1% /tmp
/dev/xvda128 10M 1.3M 8.7M 13% /boot/efi
tmpfs 95M 0 95M 0% /run/user/1000

Can anyone help me? Thanks!

You only have 475MiB free space on the /tmp partition, nowadays this is almost nothing. Jenkins has a default of 1GiB for free disk space. You can disable the free tmp space monitor by going to computer/configure and unchecking the Free Temp Space or reducing the threshold

HI, again

I have created a new instance with more space and loading 2GB to the temporary instance and when launching the agent it shows the same message.
This is the df -h now

Filesystem Size Used Avail Use% Mounted on
devtmpfs 4.0M 0 4.0M 0% /dev
tmpfs 475M 0 475M 0% /dev/shm
tmpfs 190M 3.0M 187M 2% /run
/dev/xvda1 20G 2.8G 18G 14% /
tmpfs 2.0G 0 2.0G 0% /tmp
/dev/xvda128 10M 1.3M 8.7M 13% /boot/efi
tmpfs 95M 0 95M 0% /run/user/1000

Can it be something temporary when docker is running?
This is my instruction with a volume so that jenkins data persist
docker run -p 8080:8080 -v jenkins_home:/var/jenkins_home jenkins/jenkins

Have you tried disabling the monitor as described?
Is this happening for the controller (built-in) or is this happening for agents that you dynamically spawn using ec2-plugin?

Where is the option to disable monitoring?
in the ami configuration in the cloud?
there is a Monitoring option, but I have not checked it and in the node properties there are the options
Disable deferred wipeout on this node
Disk Space Monitoring Thresholds
Tool Locations
Environment variables
but I don’t have any checked either.
The built-in node does not show any problem, it is when I provision new nodes.

Go to <jenkins_url>/computer/configure, or from the UI Manage JenkinsNodes and then click on Node Monitoring (latest LTS) or Configure Monitors (on latest weekly)

Now yes, finally, thank you very much.
I was in Configure Monitors in the nodes section.
Indeed, by deactivating the offline agents the node is operative. Thank you very much.
But I would like to know how to run my agents without getting space alerts, because I understand that it will be the optimal configuration.
Is it because of the type of ec2 (t2micro)?
Because of the ami (Amazon Linux) that loads this /tmp configuration?
The way I run the jenkins image in docker with the volume?
Thank you very much for your attention Markus!

Seems you’re using a weekly of Jenkins as you listed the Disk Space Monitoring Thresholds as available node properties. When you check this you can define node specific thresholds. If that is also available with the Jenkins configuration of your AMI cloud then you can set here the threshold to 0 which will disable the check for the agent.