Artifact download of large zip files

Large artifact zip files fail to download. Smaller artifacts work fine.

Hi there,

“it doesn’t work” is always hard to remote debug. Try to always include these 3 things.

  1. what did you try? (Code samples, command lines, screenshots, videos, etc)
  2. what did happen? (Error messages, description, outputs, stuff)
  3. what did you expect to happen?

Otherwise, it’s hard for us to get into your context and you’ll have to have someone who is exactly knowledgeable come along.

Thanks for feedback.
I’ve installed Jenkins on Redhat Linux on a local VM. I successfully ran a job and created some artifacts, some folders that created from my job. When I try to download them all at once i get Failed network error. However, if I travers deeper into the artifacts and take smaller portions/zip files it all works fine.

Are there any exceptions in the Jenkins logs? Can you monitor using the Chrome network watcher in the dev tools to see if some timeout or similar occurs? How large is large and how small is small?

I don’t see anything in the log folders. Is there a specific one I should look at? The only noticeable thing I see with network watcher is the amount of time it’s taking to for the larger (234ms) file vs. the smaller one (125ms). The folder that fails to download is 47M the one that passes is 28M. Is there some sort of timeout build into Jenkins or Chrome?

I’m thinking this might have to do with my company blocking specific files within that zip. I tried downloading on my Linux machine and it worked fine. I tried downloading only specific files on my Win machine and got an error message that the company has blocked the file download.


Thanks for the feedback @jcosta :+1: