Zipped contents of Jar and .platform files but Elastic beanstalk nginx conf not extented

Hello, I have zipped both the jar and .platform files and deployed into aws elastic beanstalk. But the elastic beanstalk is not taking the configuration to extend it’s capabilities. where as when i manually zip the files and upload it takes the configuration.
I am using the below command to zip the files: zip -r abc-0.0.1-SNAPSHOT.jar .platform/*
Also when I check the Elastic Beanstalk logs I’m getting and upstream config. error (111: Connection refused)
Why are the files being zipped from Jenkins and deployed to elastic beanstalk not accepted?

This doesn’t feel like a jenkins issue.

Have you tried troubleshooting to eliminate parts? Have you tried downloading the zip from jenkins to confirm what your zipping is is the right format? Have you tried uploading the zip without jenkins to see if jenkins is uploading incorrectly?

Yes I have downloaded the file and manually zipped them and uploaded to Elastic Beanstalk. It works. The issue occurs when zipping the files in Jenkins.

What are you wanting from us? Sounds like the zip you are making is incorrect.

What do you need to do to change it?

This is the way i’ve zipped the file, is there an another way to zip it ? as this seems to zip the files in a wrong manner.

As I keep asking, What’s wrong with it? We can’t help fixing something we don’t know about