Matrix Authorization Strategy 3.0: "No type prefix:...."

Hello,
I’ve update Matrix “Authorization Strategy” plugin from 2.6.11 to 3.0.
Now on the “Assign Roles” configuration page, all users/groups are prefixed by:
" No type prefix:" in red.
I’ve understood that the new plugin needs adaptations. (https://plugins.jenkins.io/matrix-auth/#releases)
I’ve tried to delete the users and add them newly. But as soon as I reload the page after “Save” or “Apply”, I’m back in the same situation.
What do I need to do ?
Regards
Martin

cc @danielbeck who wanted to know about any documentation issues

I believe you want to prefix with… actually I don’t know, based on PRs I’ve seen, I’m guessing GROUP: or USER: prefixes.

Though sounds like a UI bug, so you might want to make a jira.

1 Like

Thanks !
Yes, with
USER:
it gets accepted.
Created [JENKINS-67387] "No type prefix: " in "Assign roles:" after updating "Matrix Authorization Strategy" to 3.0 - Jenkins Jira

Update: Unfortunately, it seems my account has lost the “Admin” permissions. Quite bad, locked myself out for the moment…

In home/config.xml I found:

...
  <roleMap type="globalRoles">
  <role name="admin" pattern=".*">
   <permissions>
....
  <permission>hudson.model.Hudson.Administer</permission>
....
  </permissions>
   <assignedSIDs>
...
  <sid>USER:jm044248</sid>
....

jm044248 is me - so I would assume, I should have the Admin permissions, but…

You can disable security via Disable Access Control and then re-enable it.

I haven’t upgraded to the most recent version yet (lazy), so I can’t help sorry.

I didn’t realize, that there is another plugin involved here: role-strategy.
And that does not have a compatible update yet.
(see [JENKINS-67387] "No type prefix: " in "Assign roles:" after updating "Matrix Authorization Strategy" to 3.0 - Jenkins Jira)
Sorry for the confusion - had been too late in the evening yesterday.
(I only had the chance to update plugins in the evening, when our users are out - so I tried to do that, just to run into this issue)

I got myself the admin rights back, by first stopping Jenkins the brutal way, by killing jenkins.war with no job running and then manually downdating the matrix-authorization plugin and hand-editing config.xml. (uffff…)

Reported to role strategy plugin as [JENKINS-67422] Role-strategy compatibility with matrix-auth 3.0 - Jenkins Jira