Job DSL cannot find GlobalConfigFiles class

I have updated the Job DSL plugin from 1.53 to 1.87 and then it cannot find the class GlobalConfigFiles when I run jobdsl files:

FATAL: org/jenkinsci/plugins/configfiles/GlobalConfigFiles
java.lang.ClassNotFoundException: org.jenkinsci.plugins.configfiles.GlobalConfigFiles
	at java.base/
	at jenkins.util.URLClassLoader2.findClass(
	at java.base/java.lang.ClassLoader.loadClass(
	at java.base/java.lang.ClassLoader.loadClass(
Caused: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/configfiles/GlobalConfigFiles
	at javaposse.jobdsl.plugin.JenkinsDslScriptLoader.extractGeneratedItems(
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

I have tried to make a second Jenkins installation from scratch and on that I can run the same jobdsl file without that problem. Same version of Java 17 and Jenkins 2.426.3. Plugins are updated to newest version (but it also failed with the older ones I had before). My production Jenkins has more plugins than the new test Jenkins however.

I cannot figure out where the org.jenkinsci.plugins.configfiles.GlobalConfigFiles class is supposed to be located, so I have not managed to check if it is actually present on the two systems. Is it part of the jenkins.war file or is it part of the configuration plugin?

that class comes from Config File Provider plugin

Thanks, I removed that plugin and now my JobDSL scripts work again. Now I have to find out if I can live without that plugin.