Jenkins says fatal Repository not found

Error status code 108

We have tried with Github App approach and Username/PAT methods. But none of them working at the moment.

And I have admin right on these git repos. Please advise what is wrong here.

If you’re running on a very old version of command line git, it may not be able to authenticate with GitHub. You could test that theory by running the command git --version. If it is command line git 1.8 or older, then you may need to update the version of command line git.

Another alternative would be to enable JGit and then use JGit instead of command line git to perform the clone.

Another alternative would be to switch from HTTPS authentication to instead use ssh private key authentication. The URL for ssh private key authentication would be git@github.com/FinastraRubix/provartesting.git

It is also possible that the location that is checking the https://github.com URL does not have network access to the github.com site.

Thanks @MarkEWaite . The issue got resolved after removing the old credentials (from windows credential manager and as well as credentials.xml under .jenkins folder) , clearing cache and history. Restarted Jenkins. Added new creds. It worked. Not sure If Jenkins was still using the old repo creds though we added new creds and selected the same for usage. Do you know if that’s a known issue of using old creds in cache or something from Jenkins ? Thanks in advance!

The git plugin does not manage credentials with the Windows credentials manager. If an agent has Windows credentials manager configured, the plugin hopes that it is configured in a way that helps the user.

I’ve considered extending the git plugin and git client plugin to use credential managers, but there are some interestingly complex problems hiding in an attempt to use git credentials managers across multiple platforms (Windows, Linux, FreeBSD, OpenBSD, etc.) and multiple versions of command line git (1.9, 2.11, 2.17, 2.22, 2.35, 2.36, …). The plugin already knows a little too much about which versions of command line git support which features.