Is WebSocket transport idle timeout configurable?

When using the “new” WebSocket agents transport, it appears there’s some idle timeout set (which I think is 5 minutes), I’ve encountered this in pipeline where there’s no output for over 5 minutes, and the job is killed.

While I understand the purpose of the timeout, I have some long running processes (which sadly aren’t mine and don’t provide any verbosity setting), I’d also hate to have another process running just spewing output every few seconds to combat this, is there a way for this to be configured?
I haven’t found any

Do you use Kubernetes?
If that’s the case, you could maybe track this issue.
The workaround seems to be setting a value for two parameters:

-Dkubernetes.websocket.timeout=60000 -Dorg.csanchez.jenkins.plugins.kubernetes.pipeline.ContainerExecDecorator.websocketConnectionTimeout=90