Integration with Gitlab only triggered by a single branch

Gitlab version 11.11
Jenkins version 2.318

I have a gitlab project with Jenkins integration. I have been using Jenkins integrations for years without any issues. The workflow is as follows:

Push to Gitlab branch → Jenkins Builds

Recently, I deleted some branches in our Gitlab project and created some new ones. The only legacy branch, ‘dev9’, is the only one that seems to trigger Jenkins to build. None of the newly created branches are triggering Jenkins. I have tried configuring Jenkins to build the new branches as well as all branches, but it will only get triggered if the push is to the one branch.

Here is what I have tried:
dev9 branch: triggers fine
New branch from dev9: doesn’t trigger
New gitlab project with new repo and new branches: triggers fine
New gitlab project with repo pushed from original project (mentioned at the top): only push to dev9 branch triggers

This is extremely frustrating and any help would be greatly appreciated. Thanks!