"ErrorCode 3" running some exe files! What?

Hi all,

I am getting errorcode 3 running some exe files in windows, which is “file not found”.
I have tried to run them in a declative pipeline and from batch scripts.

I have found that windows exe files such as “calc.exe” work perfectly but the ones I am trying to
run that are unreal engine exe files do not. The only info im getting is:

" ERROR: script returned exit code 3
Finished: FAILURE"

I have checked the paths for oddness and tweaked file permissions.
None of this happens on command line, this is only when run from Jenkins.

Has anyone any idea what this could be?


Could be that the exe requires a DLL that is not found.
Can you run the exe on a command prompt? If yes is the “path” environment the same when run from Jenkins?

to add to that, echo env.PATH or bat("echo %PATH%") can help debug that.

Thank you for the suggestions. I tried adding the contents of the windows path to the jenkins path. Also I tried running the exe while in the exe directory as well as in the project root. No change to the output which is still :

"ERROR: script returned exit code 3
Finished: FAILURE"

It’s an odd error, I don’t see much about it online. Here is my declarative step:

stage('Run Editor tests')
            bat """
            pushd "D:\\UE\\FPS_game_UE4\\ShooterGame"
            "D:\\UE\\UE425\\Engine\\Binaries\\Win64\\UE4Editor-Cmd.exe" "D:\\UE\\FPS_game_UE4\\ShooterGame\\ShooterGame.uproject" -execcmds="Automation RunAll"  -unattended -nopause -TestExit="Automation Test Queue Empty" -log=RunTests.log -ReportOutputPath="${workspace}\\UnitTestsReport"

Welcome to this community @James :wave:
So you’re telling us that you can’t even execute the binaries outside of Jenkins? :thinking: