Editable email plugin sending a zip file as TWO files, each with a different length and the same name

Jenkins setup:
2.414.2 RHEL7.9, Editable email plugin: 2.102


If I attach one zip or gz file with the editable plugin, the email comes through ok.
If I attach multiple non-zipped/gzipped files, the email comes through ok
if I attach a zip or gz file PLUS anything else, the plugin generates an email with TWO files for the ZIP, each being about 5kB different in size yet named the same. In other words, if I attach a .zip and a .txt, I actually get THREE files attached in the email

For example, if I attach the ascii build log (an option in the editable email plugin) and a .zip file, I get THREE files attached to the email (not 2 as expected) sent by the plugin:the build log, and TWO zip files each with the same name but differing in length, only one of which is valid.

The Zip file is closed out long before the email is being sent, it’s not an issue with the zip file being incomplete, and, even if were to be the case, I wouldn’t expect TWO files with the same name to be sent.

Things I have tried:

  1. from CLI, I did a “mail -a file.zip -a file.txt -s “test” “me@domain.com”” → worked perfectly which means my email server on my box is able to send attachments properly.
  2. various Charset encodings
  3. HTML and plain text email formatting