After Upgrading to Latest version Jenkins not working

I recently upgraded to Latest version of jenkins.
After this process i facing this error
“java.lang.NoClassDefFoundError: org/jruby/javasupport/proxy/InternalJavaProxy”

can’t see from the error message, but at least one of your plugins is using the old runtimes that are no longer supported.

1 Like

Hi @halkeye
I can’t able to even login
Shall i delete these plugin from jenkin’s plugin folder.
is enough for delete these plugin’s folder only or need delete .jpi and .bak files also ?

I’d recommend deleteing the jpi file at the very least, but folder and bak are probably good ideas.
Once they are deleted, restart

Hi @halkeye
issue still persist

if you are getting the same error as the original screenshot, it means you have plugins that are using jruby. Take a look at the blog post, see if it lists any plugins you are using, and remove them.

Otherwise remove all plugins, and add back the ones you are using.

I upgraded from 2.346 to 2.387 (also upgraded from jdk8 to jdk11) and got the same error.
After deleting plugins’ own folder and .jpi files of “gitlab hook” and “ruby-runtime” plugins, It works.

1 Like