# Trying to upgrade Jenkins from Java 8 to Java 11 but getting LDAP plugin error

**URL:** <https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603>\
**Category:** Ask a question\
**Created:** [September 2, 2022, 1:48pm UTC](https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603 "2022-09-02T13:48:36Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![impulse0022](https://avatars.discourse-cdn.com/v4/letter/i/77aa72/32.png) [@impulse0022](https://community.jenkins.io/u/impulse0022)\
**Post date:** [September 2, 2022, 1:48pm UTC](https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603/1 "2022-09-02T13:48:36Z")

</div>

We are trying to upgrade Jenkins 2.346.2 running on Tomcat 9 from Java 8 to Java 11 but we are getting a failure on startup. Tomcat 9 itself will run fine on Java 11 but Jenkins fails to start properly.

To change from Java 8 to Java 11 we are modifying:  
E:\Tomcat 9.0\bin\Tomcat9w.exe (Java tab)

From (Java 8):  
C:\Program Files\AdoptOpenJDK\jdk-8.0.292.10-hotspot\jre\bin\server\jvm.dll

To (Java 11):  
C:\Program Files\Eclipse Adoptium\jdk-11.0.15.10-hotspot\bin\server\jvm.dll

We are using the LDAP plugin version 2.11:

> **[LDAP](https://plugins.jenkins.io/ldap/#documentation)**
>
> Adds LDAP authentication to Jenkins

Any insight you can provide into this error would be appreciated. Is there some type of session cache file that we need to delete as part of switching from Java 8 to Java 11?

E:\Tomcat 9.0\bin\tomcat9-stderr.2022-09-01.log  
01-Sep-2022 11:14:49.590 INFO [main] hudson.WebAppMain.contextInitialized Jenkins home directory: E:\JenkinsHome found at: EnvVars.masterEnvVars.get(“JENKINS\_HOME”)  
01-Sep-2022 11:14:49.808 SEVERE [main] org.apache.catalina.session.StandardManager.startInternal Exception loading sessions from persistent storage  
java.lang.ClassNotFoundException: hudson.security.LDAPSecurityRealm$DelegatedLdapAuthentication  
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1365)  
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1188)  
at java.lang.Class.forName0(Native Method)  
at java.lang.Class.forName(Class.java:348)  
at org.apache.catalina.util.CustomObjectInputStream.resolveClass(CustomObjectInputStream.java:159)  
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1986)  
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1850)  
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:2160)  
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1667)  
at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:2405)  
at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:2329)  
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:2187)  
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1667)  
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:503)  
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:461)  
at org.apache.catalina.session.StandardSession.doReadObject(StandardSession.java:1587)  
at org.apache.catalina.session.StandardSession.readObjectData(StandardSession.java:1040)  
at org.apache.catalina.session.StandardManager.doLoad(StandardManager.java:218)  
at org.apache.catalina.session.StandardManager.load(StandardManager.java:162)  
at org.apache.catalina.session.StandardManager.startInternal(StandardManager.java:354)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5194)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:717)  
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:690)  
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:706)  
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:978)  
at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1848)  
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)  
at java.util.concurrent.FutureTask.run(FutureTask.java:266)  
at org.apache.tomcat.util.threads.InlineExecutorService.execute(InlineExecutorService.java:75)  
at java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:112)  
at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:773)  
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:427)  
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1576)  
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:309)  
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:123)  
at org.apache.catalina.util.LifecycleBase.setStateInternal(LifecycleBase.java:423)  
at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:366)  
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:936)  
at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:843)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1384)  
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1374)  
at java.util.concurrent.FutureTask.run(FutureTask.java:266)  
at org.apache.tomcat.util.threads.InlineExecutorService.execute(InlineExecutorService.java:75)  
at java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:134)  
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:909)  
at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:262)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:421)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:930)  
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)  
at org.apache.catalina.startup.Catalina.start(Catalina.java:772)  
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)  
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)  
at java.lang.reflect.Method.invoke(Method.java:498)  
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:342)  
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:473)

---

<div class="post-metadata">

**Author:** ![impulse0022](https://avatars.discourse-cdn.com/v4/letter/i/77aa72/32.png) [@impulse0022](https://community.jenkins.io/u/impulse0022)\
**Post date:** [September 2, 2022, 2:33pm UTC](https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603/2 "2022-09-02T14:33:34Z")

</div>

I also tried updating the LDAP plugin from 2.11 to 2.12 (latest) and get the same error mentioned above when trying to use Java 11. Works fine using Java 8.

---

<div class="post-metadata">

**Author:** ![halkeye](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/halkeye/32/8_2.png) [@halkeye](https://community.jenkins.io/u/halkeye)\
**Post date:** [September 2, 2022, 4:26pm UTC](https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603/3 "2022-09-02T16:26:53Z")

</div>

Recommend you open an issue - [Report an issue in a plugin](https://www.jenkins.io/participate/report-issue/redirect/#17122)

---

<div class="post-metadata">

**Author:** ![impulse0022](https://avatars.discourse-cdn.com/v4/letter/i/77aa72/32.png) [@impulse0022](https://community.jenkins.io/u/impulse0022)\
**Post date:** [September 2, 2022, 4:45pm UTC](https://community.jenkins.io/t/trying-to-upgrade-jenkins-from-java-8-to-java-11-but-getting-ldap-plugin-error/3603/4 "2022-09-02T16:45:10Z")

</div>

Thanks for the suggestion. I opened an issue:  
[https://issues.jenkins.io/browse/JENKINS-69508](https://issues.jenkins.io/browse/JENKINS-69508)
