# Post build not running

**URL:** <https://community.jenkins.io/t/post-build-not-running/2532>\
**Category:** Ask a question\
**Created:** [May 24, 2022, 7:42am UTC](https://community.jenkins.io/t/post-build-not-running/2532 "2022-05-24T07:42:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amir](https://avatars.discourse-cdn.com/v4/letter/a/c37758/32.png) [@Amir](https://community.jenkins.io/u/Amir)\
**Post date:** [May 24, 2022, 7:42am UTC](https://community.jenkins.io/t/post-build-not-running/2532/1 "2022-05-24T07:42:09Z")

</div>

hi all,  
i have a problem that start around 2 weeks ago.  
when i run the POST Build it failed but when i run it Manually it work.  
i even try to create a new POST that only copy txt file to my Sheard folder with out any success.

_this is the batch command_ :  
echo %BUILD\_TAG%  
echo GIS

echo test \> test.txt  
dir \itnas\managix  
xcopy test.txt \itnas\Managix\text.txt /E /Y /I

**this is the console output**  
Started by user [Jenkins Admin](http://jenkins-srv01.managix.local:8080/user/jenkins.admin) Building on master in workspace C:\Jenkins\workspace\temp\_test [WS-CLEANUP] Deleting project workspace… [WS-CLEANUP] Done [temp\_test] $ cmd /c call C:\Users\JENKIN~1.ADM\AppData\Local\Temp\hudson4481171873961108583.bat C:\Jenkins\workspace\temp\_test\>echo jenkins-temp\_test-10 jenkins-temp\_test-10 C:\Jenkins\workspace\temp\_test\>echo GIS GIS C:\Jenkins\workspace\temp\_test\>echo test 1\>test.txt C:\Jenkins\workspace\temp\_test\>dir \itnas\managix The referenced account is currently locked out and may not be logged on to. C:\Jenkins\workspace\temp\_test\>xcopy test.txt \itnas\Managix\text.txt /E /Y /I Invalid drive specification 0 File(s) copied C:\Jenkins\workspace\temp\_test\>exit 4 Build step ‘Execute Windows batch command’ marked build as failure Finished: FAILURE

---

<div class="post-metadata">

**Author:** ![halkeye](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/halkeye/32/8_2.png) [@halkeye](https://community.jenkins.io/u/halkeye)\
**Post date:** [May 24, 2022, 7:45am UTC](https://community.jenkins.io/t/post-build-not-running/2532/2 "2022-05-24T07:45:17Z")

</div>

> [@Amir](#):
>
> Invalid drive specification

I don’t know much windows stuff but isn’t that the error there?

---

<div class="post-metadata">

**Author:** ![Amir](https://avatars.discourse-cdn.com/v4/letter/a/c37758/32.png) [@Amir](https://community.jenkins.io/u/Amir)\
**Post date:** [May 24, 2022, 8:28am UTC](https://community.jenkins.io/t/post-build-not-running/2532/3 "2022-05-24T08:28:25Z")

</div>

I know the error is there, the issue is that when the post build run it failed ( with the Xcopy command )

The batch command is : (Part of it)

echo %BUILD\_TAG%

echo GIS

xcopy S\Sources\Server\SMNG.Server.Geo\Services\GISServer\Web \itnas\Managix\Jenkins\Trunk\Server%BUILD\_DISPLAY\_NAME%\SMNG\GISServer\Web /E /Y /I

The Console Output :

C:\Jenkins\workspace\Trunk\_Server\_Post\>xcopy S\Sources\Server\SMNG.Server.Geo\Services\GISServer\Web \itnas\Managix\Jenkins\Trunk\Server#673\SMNG\GISServer\Web /E /Y /I

Invalid drive specification

0 File(s) copied

When I run the Xcopy command without the S it running….

![image001.png](https://europe1.discourse-cdn.com/flex013/uploads/jenkins/original/2X/0/0b69f6128f2cd787e31460dbc65d5cac5e495d01.png)

---

<div class="post-metadata">

**Author:** ![kon](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/kon/32/1197_2.png) [@kon](https://community.jenkins.io/u/kon)\
**Post date:** [May 24, 2022, 11:07am UTC](https://community.jenkins.io/t/post-build-not-running/2532/4 "2022-05-24T11:07:11Z")

</div>

> [@Amir](#):
>
> The referenced account is currently locked out and may not be logged on to.

That seems to be the first error. The account is locked at the “itnas” server (if it is a local account there) or at the domain controller (if it is a domain account). Might be caused by too many failed login attempts with incorrect passwords.
