# Jenkins fails while starting it

**URL:** <https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618>\
**Category:** Ask a question\
**Tags:** question\
**Created:** [February 6, 2023, 2:54am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618 "2023-02-06T02:54:40Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![vinjenk2024](https://avatars.discourse-cdn.com/v4/letter/v/bc79bd/32.png) [@vinjenk2024](https://community.jenkins.io/u/vinjenk2024)\
**Post date:** [February 6, 2023, 2:54am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/1 "2023-02-06T02:54:40Z")

</div>

While starting jenkins its getting failed the automation service ```  
Failed to start LSB: Jenkins Continuous Integration Server.

```auto
Please help asap
```

---

<div class="post-metadata">

**Author:** ![MarkEWaite](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/markewaite/32/20_2.png) [@MarkEWaite](https://community.jenkins.io/u/MarkEWaite)\
**Post date:** [February 6, 2023, 5:05am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/2 "2023-02-06T05:05:53Z")

</div>

Hi there,

“it doesn’t work” is always hard to remote debug. Try to always include these 3 things.

1. what did you try? (Code samples, command lines, screenshots, videos, etc)
2. what did happen? (Error messages, description, outputs, stuff)
3. what did you expect to happen?

Otherwise, it’s hard for us to get into your context and you’ll have to have someone who is exactly knowledgeable come along.

You might refer to the following articles as possible sources of help while you investigate:

> [@Not able to start Jenkins in linux](https://community.jenkins.io/t/not-able-to-start-jenkins-in-linux/5543/6):
>
> Hi Mark Thank you so much for quick updates. We had old pkg jenkins-2.164.3-1.1.noarch working on this, after linux patches, Jenkins service is not coming up. then we removed old pkg and installed new pkg “jenkins-2.361-1.1.noarch” using rpm -i jenkins-2.361-1.1.noarch we can’t do yum install, since not connected to outside. Does 2.361 uses systemd? Thank you.

> [@Service failed to startup due to timeout](https://community.jenkins.io/t/service-failed-to-startup-due-to-timeout/5242):
>
> I also experience the same issue on Rocky Linux 8. I followed the steps in Jenkins page for Redhat/CentOS. So I tried to increase the timeout setting as suggested, from 90s to 300s to 600s but still jenkins wont complete to start and the status is still activating. ~# systemctl show jenkins | grep ^Timeout TimeoutStartUSec=1min 30s TimeoutStopUSec=1min 30s ~# ~# systemctl edit jenkins ~# systemctl show jenkins | grep ^Timeout TimeoutStartUSec=5min TimeoutStopUSec=1min 30s ~# ~# time s…

> [@Job for jenkins.service failed because a timeout was exceeded](https://community.jenkins.io/t/job-for-jenkins-service-failed-because-a-timeout-was-exceeded/2443):
>
> I have installed OpenJDK-11-JRE root@admincp:~# java -version openjdk version "11.0.15" 2022-04-19 OpenJDK Runtime Environment (build 11.0.15+10-Ubuntu-0ubuntu0.20.04.1) OpenJDK 64-Bit Server VM (build 11.0.15+10-Ubuntu-0ubuntu0.20.04.1, mixed mode, sharing) The following error occurred in installing Jenkins root@admincp:~# apt install -y jenkins Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed …

> [@Job for jenkins.service failed because a timeout was exceeded](https://community.jenkins.io/t/job-for-jenkins-service-failed-because-a-timeout-was-exceeded/2443):
>
> I have installed OpenJDK-11-JRE root@admincp:~# java -version openjdk version "11.0.15" 2022-04-19 OpenJDK Runtime Environment (build 11.0.15+10-Ubuntu-0ubuntu0.20.04.1) OpenJDK 64-Bit Server VM (build 11.0.15+10-Ubuntu-0ubuntu0.20.04.1, mixed mode, sharing) The following error occurred in installing Jenkins root@admincp:~# apt install -y jenkins Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed …

> [@Installing on Ubuntu, getting Service fails with result "timeout" on apt install](https://community.jenkins.io/t/installing-on-ubuntu-getting-service-fails-with-result-timeout-on-apt-install/4882):
>
> When installing on Ubuntu via directions provided by [Install directions](https://www.jenkins.io/doc/book/installing/linux/) I am getting the service and install to fail. \> apt install jenkins ... Do you want to continue? [Y/n] y (Reading database ... 144296 files and directories currently installed.) Removing jenkins (2.375.1) ... (Reading database ... 144287 files and directories currently installed.) Purging configuration files for jenkins (2.375.1) ... failed to remove jenkins system user Scanning processes... Scanning processor microcode... …

> [@Installation of Jenkins on centos](https://community.jenkins.io/t/installation-of-jenkins-on-centos/4228/2):
>
> Hi there, Jenkins 2.332.1 switched Jenkins from using System V init to use systemd with its Linux package installers for Debian, Ubuntu, Red Hat, Alma, openSUSE, Rocky, and more. The [LTS Upgrade Guide](https://www.jenkins.io/doc/upgrade-guide/2.332/#upgrading-to-jenkins-lts-2-332-1) describes that transition and how to adapt your environment to the transition. There is a [blog post](https://www.jenkins.io/blog/2022/03/25/systemd-migration/) about it as well at There is also a [video introduction](https://www.youtube.com/watch?v=MkokjTQ2ngc) for RPM based distributions like Red Hat Enterprise Linux, Alma Linux, Rocky Linux, Oracle Linux, and Amazon Linux. [[🔴 Managing…](https://www.youtube.com/watch?v=MkokjTQ2ngc)

---

<div class="post-metadata">

**Author:** ![vinjenk2024](https://avatars.discourse-cdn.com/v4/letter/v/bc79bd/32.png) [@vinjenk2024](https://community.jenkins.io/u/vinjenk2024)\
**Post date:** [February 6, 2023, 5:12am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/3 "2023-02-06T05:12:08Z")

</div>

Hello Mark,  
We have upgraded jenkins from 2.289 to 2.319 and after start getting error .  
[root@-jenkins system]# systemctl status jenkins  
● jenkins.service - Jenkins - open source automation server  
Loaded: loaded (/etc/systemd/system/jenkins.service; static; vendor preset: disabled)  
Active: failed (Result: exit-code) since Sat 2023-02-04 09:18:21 UTC; 1 day 19h ago  
Process: 20674 ExecStart=/etc/init.d/jenkins start (code=exited, status=1/FAILURE)  
Main PID: 20674 (code=exited, status=1/FAILURE)  
CGroup: /system.slice/jenkins.service  
├─ 3912 runuser -s /bin/bash jenkins -c ulimit -S -c 0 \>/dev/null 2\>&1 ; /usr/lib/jvm/java-11-openjdk-11.0.14.1.1-1.el7\_9.x86\_64/bin/java -Djava.awt.headless=true -Dhud…  
├─ 3913 bash -c ulimit -S -c 0 \>/dev/null 2\>&1 ; /usr/lib/jvm/java-11-openjdk-11.0.14.1.1-1.el7\_9.x86\_64/bin/java -Djava.awt.headless=true -Dhudson.security.csrf.Global…  
├─ 3914 /usr/lib/jvm/java-11-openjdk-11.0.14.1.1-1.el7\_9.x86\_64/bin/java -Djava.awt.headless=true -Dhudson.security.csrf.GlobalCrumbIssuerConfiguration.DISABLE\_CSRF\_PRO…  
├─12439 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumulushelloUI5)  
├─12443 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/LSC%20Mobility/_git/dsproveoutbounddelivery)  
├─12446 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/Midstream%20Maui/_git/xbiz-ds-autosettlerule)  
├─12448 git-remote-https [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumulushelloUI5) [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumulushelloUI5)  
├─12451 git-remote-https [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/LSC%20Mobility/_git/dsproveoutbounddelivery) [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/LSC%20Mobility/_git/dspro)…  
├─12457 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumuluscsbmaintain)  
├─12458 git-remote-https [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/Midstream%20Maui/_git/xbiz-ds-autosettlerule) [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/Midstream%20Maui/_git/xb)…  
├─12463 git-remote-https [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumuluscsbmaintain) [Azure DevOps Services | Sign In](https://sede-gf-hse.visualstudio.com/Cumulus/_git/gfcumuluscsbmaintain)  
├─12476 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-it-itso.visualstudio.com/SAC%20Data%20Import%20and%20Self%20Service/_git/dvopsdsui5hello)  
├─12480 git-remote-https [Azure DevOps Services | Sign In](https://sede-it-itso.visualstudio.com/SAC%20Data%20Import%20and%20Self%20Service/_git/dvopsdsui5hello) [Azure DevOps Services | Sign In](https://sede-it-itso.visualstudio.com/SAC)…  
├─12481 git ls-remote -h [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/Product%20Master%20Auto%20creation%20at%20header%20level/_git/opex-ds-lsc-autolube)  
├─12485 git-remote-https [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/Product%20Master%20Auto%20creation%20at%20header%20level/_git/opex-ds-lsc-autolube) [https://sede-ds-adp.vis](https://sede-ds-adp.vis)…  
└─12503 git-remote-https [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/LSC%20Mobility/_git/dsproveoutbounddelivery) [Azure DevOps Services | Sign In](https://sede-ds-adp.visualstudio.com/LSC%20Mobility/_git/dspro)…

Feb 04 09:18:17 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) systemd[1]: Starting Jenkins - open source automation server…  
Feb 04 09:18:17 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) runuser[20679]: pam\_unix(runuser:session): session opened for user jenkins by (uid=0)  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) runuser[20679]: pam\_unix(runuser:session): session closed for user jenkins  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) jenkins[20674]: Starting Jenkins [FAILED]  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) systemd[1]: jenkins.service: main process exited, code=exited, status=1/FAILURE  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) systemd[1]: Failed to start Jenkins - open source automation server.  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) systemd[1]: Unit jenkins.service entered failed state.  
Feb 04 09:18:21 [0801131-jenkins.sga-res-pub.com](http://0801131-jenkins.sga-res-pub.com) systemd[1]: jenkins.service failed.

Service should be ion active status please help us to sort out the issue.

---

<div class="post-metadata">

**Author:** ![MarkEWaite](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/markewaite/32/20_2.png) [@MarkEWaite](https://community.jenkins.io/u/MarkEWaite)\
**Post date:** [February 6, 2023, 5:20am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/4 "2023-02-06T05:20:28Z")

</div>

You’ll need to read the log file from that system and locate the failure message in the log file. It appears that systemd is trying to start the process but then the process is dying or being killed. The log says that the process exited. Find the log file and read it.

---

<div class="post-metadata">

**Author:** ![vinjenk2024](https://avatars.discourse-cdn.com/v4/letter/v/bc79bd/32.png) [@vinjenk2024](https://community.jenkins.io/u/vinjenk2024)\
**Post date:** [February 6, 2023, 5:35am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/5 "2023-02-06T05:35:01Z")

</div>

Hello Mark,  
Please find the logs.  
Jenkins home directory: /var/lib/jenkins found at: SystemProperties.getProperty(“JENKINS\_HOME”)  
Feb 04, 2023 8:16:51 AM INFO org.eclipse.jetty.server.handler.ContextHandler doStart  
Started w.@138fe6ec{Jenkins v2.319.3,/,file:///var/cache/jenkins/war/,AVAILABLE}{/var/cache/jenkins/war}  
Feb 04, 2023 8:16:51 AM INFO org.eclipse.jetty.util.ssl.SslContextFactory load  
x509=X509@3dd69f5a,h=[,],a=,w=) for  
Server@59a67c3a[provider=null,keyStore=null,trustStore=null]  
Feb 04, 2023 8:16:52 AM INFO org.eclipse.jetty.server.AbstractConnector doStart  
Started ServerConnector@351d0846{SSL, (ssl, http/1.1)}{0.0.0.0:8443}  
Feb 04, 2023 8:16:52 AM INFO org.eclipse.jetty.server.Server doStart  
Started @4779ms  
Feb 04, 2023 8:16:52 AM INFO winstone.Logger logInternal  
Winstone Servlet Engine running: controlPort=disabled  
Feb 04, 2023 8:16:52 AM INFO jenkins.InitReactorRunner$1 onAttained  
Started initialization  
Feb 04, 2023 8:16:54 AM INFO hudson.ClassicPluginStrategy createPluginWrapper  
Plugin build-pipeline-plugin.jpi is disabled  
Feb 04, 2023 8:16:54 AM INFO jenkins.InitReactorRunner$1 onAttained  
Listed all plugins  
Feb 04, 2023 8:16:55 AM INFO org.jvnet.hudson.plugins.backup.BackupPluginImpl loadConfiguration  
Loading configuration…  
Feb 04, 2023 8:17:10 AM INFO jenkins.InitReactorRunner$1 onAttained  
Prepared all plugins  
Feb 04, 2023 8:17:10 AM INFO jenkins.InitReactorRunner$1 onAttained  
Started all plugins  
Feb 04, 2023 8:17:14 AM INFO jenkins.InitReactorRunner$1 onAttained  
Augmented all extensions  
Feb 04, 2023 8:17:15 AM INFO hudson.slaves.SlaveComputer tryReconnect  
Attempting to reconnect SCP Fiori Build Agent  
Feb 04, 2023 8:17:15 AM INFO jenkins.InitReactorRunner$1 onAttained  
System config loaded  
Feb 04, 2023 8:17:16 AM INFO jenkins.InitReactorRunner$1 onAttained  
System config adapted  
Feb 04, 2023 8:17:17 AM INFO jenkins.InitReactorRunner$1 onAttained  
Loaded all jobs  
Feb 04, 2023 8:17:17 AM INFO jenkins.InitReactorRunner$1 onAttained  
Configuration for all jobs updated  
Feb 04, 2023 8:17:17 AM INFO hudson.model.AsyncPeriodicWork lambda$doRun$1  
Started Download metadata  
Feb 04, 2023 8:17:17 AM INFO jenkins.InitReactorRunner$1 onAttained  
Completed initialization  
Feb 04, 2023 8:17:17 AM WARNING hudson.model.DownloadService$Downloadable updateNow  
No tool installer metadata found for jenkins.plugins.nodejs.tools.MirrorNodeJSInstaller  
Feb 04, 2023 8:17:17 AM INFO hudson.model.AsyncPeriodicWork lambda$doRun$1  
Finished Download metadata. 523 ms  
Feb 04, 2023 8:17:17 AM INFO hudson.WebAppMain$3 run  
Jenkins is fully up and running  
Feb 04, 2023 8:17:27 AM INFO hudson.model.AsyncAperiodicWork lambda$doAperiodicRun$1  
Started Update IdP Metadata from URL PeriodicWork  
Feb 04, 2023 8:17:27 AM INFO hudson.model.AsyncAperiodicWork lambda$doAperiodicRun$1  
Finished Update IdP Metadata from URL PeriodicWork. 1 ms  
Feb 04, 2023 8:17:50 AM INFO hudson.model.AsyncPeriodicWork lambda$dError fetching project information  
org.sonarqube.ws.client.HttpException: Error 401 on [https://sesvc.shell.com/api/ce/task?id=AXCLqsJyx1tk-tHW6k1g](https://sesvc.shell.com/api/ce/task?id=AXCLqsJyx1tk-tHW6k1g) :  
at org.sonarqube.ws.client.BaseResponse.failIfNotSuccessful(BaseResponse.java:36)  
at hudson.plugins.sonar.client.HttpClient.getHttp(HttpClient.java:38)  
at hudson.plugins.sonar.client.WsClient.getCETask(WsClient.java:51)  
at hudson.plugins.sonar.client.SQProjectResolver.requestCETaskDetails(SQProjectResolver.java:98)  
at hudson.plugins.sonar.client.SQProjectResolver.resolve(SQProjectResolver.java:75)  
at hudson.plugins.sonar.action.SonarCacheAction.get(SonarCacheAction.java:76)  
at hudson.plugins.sonar.action.SonarCacheAction.get(SonarCacheAction.java:52)  
at hudson.plugins.sonar.action.SonarProjectActionFactory.createProjectPage(SonarProjectActionFactory.java:117)  
at hudson.plugins.sonar.action.SonarProjectActionFactory.createFor(SonarProjectActionFactory.java:83)  
at hudson.plugins.sonar.action.SonarProjectActionFactory.createFor(SonarProjectActionFactory.java:42)  
at hudson.model.Actionable.createFor(Actionable.java:114)  
at hudson.model.Actionable.getActions(Actionable.java:139)  
at hudson.model.Job.getPermalinks(Job.java:1074)  
at jenkins.model.PeepholePermalink$RunListenerImpl.onDeleted(PeepholePermalink.java:213)  
at hudson.model.listeners.RunListener.fireDeleted(RunListener.java:268)  
at hudson.model.Run.delete(Run.java:1640)  
at hudson.tasks.LogRotator.perform(LogRotator.java:180)  
at hudson.model.Job.logRotate(Job.java:468)  
at jenkins.model.JobGlobalBuildDiscarderStrategy.apply(JobGlobalBuildDiscarderStrategy.java:53)  
at jenkins.model.BackgroundGlobalBuildDiscarder.lambda$processJob$0(BackgroundGlobalBuildDiscarder.java:66)  
at java.base/java.lang.Iterable.forEach(Iterable.java:75)  
at jenkins.model.BackgroundGlobalBuildDiscarder.processJob(BackgroundGlobalBuildDiscarder.java:60)  
at jenkins.model.BackgroundGlobalBuildDiscarder.execute(BackgroundGlobalBuildDiscarder.java:54)  
at hudson.model.AsyncPeriodicWork.lambda$doRun$1(AsyncPeriodicWork.java:102)  
at java.base/java.lang.Thread.run(Thread.java:829)  
Feb 04, 2023 8:17:52 AM WARNING jenkins.model.BackgroundGlobalBuildDiscarder lambda$processJob$0

---

<div class="post-metadata">

**Author:** ![MarkEWaite](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/markewaite/32/20_2.png) [@MarkEWaite](https://community.jenkins.io/u/MarkEWaite)\
**Post date:** [February 6, 2023, 6:02am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/6 "2023-02-06T06:02:54Z")

</div>

I see no indication of the cause of the failure in that log file. You’ll need to continue looking. You may need to check operating system log files to see if the process was killed due to an out of memory condition or if it was killed due to swap space being exhausted or if it was killed due to some other reason.

---

<div class="post-metadata">

**Author:** ![vinjenk2024](https://avatars.discourse-cdn.com/v4/letter/v/bc79bd/32.png) [@vinjenk2024](https://community.jenkins.io/u/vinjenk2024)\
**Post date:** [February 6, 2023, 6:25am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/7 "2023-02-06T06:25:16Z")

</div>

Ohk  
So can u give me any guidance to check these artifacts or some specific command in case of linux.

---

<div class="post-metadata">

**Author:** ![MarkEWaite](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/markewaite/32/20_2.png) [@MarkEWaite](https://community.jenkins.io/u/MarkEWaite)\
**Post date:** [February 6, 2023, 2:41pm UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/8 "2023-02-06T14:41:13Z")

</div>

No, I cannot. I’m not willing to do remote debugging at that level.

---

<div class="post-metadata">

**Author:** ![MarkEWaite](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/markewaite/32/20_2.png) [@MarkEWaite](https://community.jenkins.io/u/MarkEWaite)\
**Post date:** [July 22, 2023, 8:58am UTC](https://community.jenkins.io/t/jenkins-fails-while-starting-it/5618/9 "2023-07-22T08:58:06Z")

</div>

A post was split to a new topic: [No space left on device is reported on restart](https://community.jenkins.io/t/no-space-left-on-device-is-reported-on-restart/8608)
