# Jenkins docker ephemeral agent fails to start

**URL:** <https://community.jenkins.io/t/jenkins-docker-ephemeral-agent-fails-to-start/7482>\
**Category:** Using Jenkins\
**Created:** [May 19, 2023, 7:18am UTC](https://community.jenkins.io/t/jenkins-docker-ephemeral-agent-fails-to-start/7482 "2023-05-19T07:18:56Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![zanderFortinbras](https://avatars.discourse-cdn.com/v4/letter/z/91b2a8/32.png) [@zanderFortinbras](https://community.jenkins.io/u/zanderFortinbras)\
**Post date:** [May 19, 2023, 7:18am UTC](https://community.jenkins.io/t/jenkins-docker-ephemeral-agent-fails-to-start/7482/1 "2023-05-19T07:18:56Z")

</div>

Here is the systems i am running  
jenkins 2.3871 , openjdk version “11.0.18” 2023-01-17, Version = 23.0.5, API Version = 1.42

from a jenkins controller i am using docker plugin to communicate to host with docker agent ephemeral agents being spun up.

But i am getting the following message on the UI.  
#5977

(pending—There are no nodes with the label ‘[dockerImage](https://tul-mgmt-jenkins-21.cardconex.local/label/dockerImage)

And in the system logs under \* [Manage Jenkins] → [System Log] → All Jenkins Logs

system log reports

Trying to run container for image “zanderfortinbras/ssh-agent:c”  
May 19, 2023 1:56:16 AM INFO com.nirima.jenkins.plugins.docker.DockerTemplate doProvisionNode

Trying to run container for node dockerImage-0006pufrihdqd from image: zanderfortinbras/ssh-agent:c  
May 19, 2023 1:56:16 AM INFO com.nirima.jenkins.plugins.docker.DockerTemplate doProvisionNode  
Started container ID 72566b92e336b15f910ede8e8eecb8c62e62ea4d7787a833e863fe4560587e64 for node dockerImage-0006pufpvzyxv from image: zanderfortinbras/ssh-agent:c  
May 19, 2023 1:56:16 AM INFO com.nirima.jenkins.plugins.docker.DockerTemplate doProvisionNode  
Started container ID  
c8d794c19d97b1f786f307104a3ae37cb696e9057a76584a3801b1c5de8610d8 for node dockerImage-0006pufrihdqd from image: zanderfortinbras/ssh-agent:c  
May 19, 2023 1:56:16 AM INFO com.nirima.jenkins.plugins.docker.DockerTemplate doProvisionNode  
Started container ID 189b573bb5cd32e73315b8d3c894fa260d039c58962e751638509d7719a7c659 for node dockerImage-0006pufr7p8sn from image: zanderfortinbras/ssh-agent:c  
May 19, 2023 1:56:37 AM WARNING com.nirima.jenkins.plugins.docker.utils.PortUtils$ConnectionCheck execute  
Could not connect to tul-mgmt-jenkins-22.cardconex.local port 35160. Are you sure this location is contactable from Jenkins?

May 19, 2023 1:56:37 AM SEVERE com.nirima.jenkins.plugins.docker.DockerCloud$1 run  
Error in provisioning; template=‘DockerTemplate{configVersion=2, labelString=‘dockerImage’, connector=DockerComputerSSHConnector{sshKeyStrategy=InjectSSHKey{user=‘jjj’}, port=portno}, remoteFs=’/home/jenkins/agent’, instanceCap=2147483647, mode=NORMAL, retentionStrategy=com.nirima.jenkins.plugins.docker.strategy.DockerOnceRetentionStrategy@29, dockerTemplateBase=DockerTemplateBase{image=‘zanderfortinbras/ssh-agent:c’, bindAllPorts=false, cpuPeriod=0, cpuQuota=0, privileged=false, tty=false}, removeVolumes=false, stopTimeout=10, pullStrategy=PULL\_ALWAYS, pullTimeout=300, disabled=BySystem,0 ms,4 min 59 sec,Template provisioning failed., name=‘dockerImage’}’ for cloud=‘docker-slave’  
java.io.IOException: SSH service hadn’t started after 20 seconds and 53 milliseconds.Try increasing the number of retries (currently null) and/or the retry wait time (currently null) to allow for containers taking longer to start.

How one come across this before.
