# Cannot connect jenkins agent node "could not locate server among" error

**URL:** <https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814>\
**Category:** Ask a question\
**Tags:** question\
**Created:** [March 30, 2024, 7:34pm UTC](https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814 "2024-03-30T19:34:43Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![smeghoo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@smeghoo](https://community.jenkins.io/u/smeghoo)\
**Post date:** [March 30, 2024, 7:34pm UTC](https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814/1 "2024-03-30T19:34:43Z")

</div>

Jenkins setup: Version 2.440.2 / Ubuntu 22.04.3 LTS

I am receiving this error when trying to run my agent.jar file

```auto
Mar 30, 2024 6:35:20 PM hudson.remoting.Launcher$CuiListener status
INFO: Locating server among [https://snm-cloud.site:8443/]
Mar 30, 2024 6:35:20 PM hudson.remoting.Launcher$CuiListener status
INFO: Could not locate server among [https://snm-cloud.site:8443/]; waiting 10 seconds before retry

```

Does anyone know why this error would get thrown?

**Could not locate server among**

---

<div class="post-metadata">

**Author:** ![StroickN](https://avatars.discourse-cdn.com/v4/letter/s/e19b73/32.png) [@StroickN](https://community.jenkins.io/u/StroickN)\
**Post date:** [April 15, 2024, 5:58am UTC](https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814/2 "2024-04-15T05:58:33Z")

</div>

I have the same issue on a Windows Server, since this weekend

---

<div class="post-metadata">

**Author:** ![StroickN](https://avatars.discourse-cdn.com/v4/letter/s/e19b73/32.png) [@StroickN](https://community.jenkins.io/u/StroickN)\
**Post date:** [April 15, 2024, 7:39am UTC](https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814/3 "2024-04-15T07:39:06Z")

</div>

for me it is solved!  
Port 58925 was blocked by a Firewall

---

<div class="post-metadata">

**Author:** ![JRStolle](https://dub1.discourse-cdn.com/flex013/user_avatar/community.jenkins.io/jrstolle/32/9981_2.png) [@JRStolle](https://community.jenkins.io/u/JRStolle)\
**Post date:** [September 4, 2024, 11:48am UTC](https://community.jenkins.io/t/cannot-connect-jenkins-agent-node-could-not-locate-server-among-error/13814/4 "2024-09-04T11:48:05Z")

</div>

@smeghoo I was wondering if the answer from Norbert solved your problem.
