After upgrading the jenkins from 2.263.1 to 2.345 jenkins service is not starting

Hi Team,

we have upgraded the jenkines from 2.263.1to 2.345 after upgrading the jenkins service i snot starting up its showing the below error.
Starting LSB: Jenkins Automation Server…
pam_unix(runuser:session): session opened for user jenkins by (uid=0)
Starting Jenkins Exception in thread “Attach Listener” Agent failed to start!
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.codehaus.groovy.vmplugin.v7.Java7$1 (file:…ss,int)
WARNING: Please consider reporting this to the maintainers of org.codehaus.groovy.vm…Java7$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective …rations
WARNING: All illegal access operations will be denied in a future release

See the instructions in the blog post.

Be sure that you read the entire blog post.

If you have not found a solution by the end of reading the blog post, then you need to provide the information that is listed in the reporting issues section of the blog post

I am curious why you decided to upgrade from an outdated long term support release to an outdated weekly release. The Jenkins project supports the most current long term support release (currently 2.332.3) and the most current weekly release (currently 2.347). Usually, you would update from an outdated long term support release to a newer long term support release.

Be sure that you performed the upgrade using the operating system package manager that installed Jenkins originally. For example, that might be yum update jenkins or apt update jenkins. Do not replace the jenkins.war file with a newer copy of that file, since that skips all the upgrade logic that is included in the operating system package installer.

1 Like

You saved my bacon! Someone at our company installed Jenkins on Rocky Linux and then left the company. When I used yum to upgrade to 2.346.2 the instance wouldn’t start anymore. Thanks to the blog post you linked, I was able to see that the override.conf file had a blank --httpPort setting. Here is the error message for posterity:

java.lang.NumberFormatException: For input string: “”
at java.base/java.lang.NumberFormatException.forInputString(
at java.base/java.lang.Integer.parseInt(
at java.base/java.lang.Integer.parseInt(
at winstone.cmdline.Option.intArg(
at winstone.cmdline.Option$OInt.get(
at winstone.HttpConnectorFactory.start(
at winstone.Launcher.spawnListener(
Caused: Failed to start a listener: winstone.HttpConnectorFactory
at winstone.Launcher.spawnListener(
at winstone.Launcher.(
at winstone.Launcher.main(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at Main._main(
at Main.main(

1 Like

Welcome to the community @rhaley and thanks a lot for your feedback. :+1:


A post was merged into an existing topic: Migrating Jenkins